Upgrade to newest version 2.43b5 not worked
  • Genuine basecam 32bit board successfully running previous versions ok for several months. Flashed to latest version, when I reconnect using usb board buzzer just beeps fast GUI shows Board Ver. 3.0 Firmware shows 0.00 b0 the flash seems to go ok.
    Green led flashes fast and red is on continuous.

    Tried the recovery by shorting the flash pins. No change.
    Confirmed using matched GUI to version.
  • Now I can't connect to the board at all, using flash jumper or not. Just solid red LED and nothing. This is the second board that's failed, I had an 8bit board that did this last year!! I can't afford to keep replacing these.
  • OK, now I've got it back to the original 'non working' state as per my first post.
  • Bit more info.
    When I connect the percentage bar rises up to 100% in about 20 seconds then I get the message:
    'Something goes wrong reading parameters
    Error reading params for profile 0.....4'
    Error reading adj.variables'

    Red LED on Green LED flashing approx twice per second.

    Not sure if this affects it but I currently don't have the IMU or motors connected.
  • "Problem" solved! But it wasn't a problem, just me not knowing how the new version requires the IMU's to be connected or it will not load the params etc. I'll leave this post up in case others happen to connect the board without IMU like me and then get confused!
  • Zeb, thank you for sharing your experience. I was having the same problem and your thread helped me resolve it.

    I just wanted to add a note that both the frame and camera IMU need to be connected for this to work. I tried with a single IMU and had the same "Something goes wrong reading parameters" error.

    FYI, I saw the same behavior on Mac and PC versions of SimpleBGC.
  • Adam, good to know! Thanks.
    Things have moved on a fair bit since the basic 8 bit board.