inaccurate yaw (aerial)
  • 32bit is working very great and i found superb pid settings for pitch and roll axis.
    for yaw i tried everything but it seems to me its lot more inaccurate than pitch roll.

    because best setting i get in aerial mode is yaw I setting at 0.01. everything higher pid settings getting more worse.

    is there any chance to get better result in this axis? yaw axis is a bit bumpy shaking from left to right
  • I think this might be couple of things.

    1. how steady the gimbal is and how well is it balanced.

    2. how steady is the installation platform, and by this I mean, if above yaw there is just the installation plate and vibration dampers, this probably is the problem, there is not enough mass. It is not actually the gimbal that is vibrating, but the installation. This could be improved by adding mass to above yaw, and as it is flying platform and additional mass would not be good, so I would propose the batteries. This would probably improve vibration dampening also.
  • Are you rotating both camera and landing gear as in the Cinestar 6 or 8 tripod yaw motor cage landing gear or just the camera. The tripod yaw motor cage adds a lot of extra rotational momentum that has to be overcome with Yaw PID loop control. It can also wreak havoc with Yaw PID loop control when flying in wind or forward quickly..... due to reverse weather vane affect on landing gear.
  • thanks for your suggestions!

    i have external landing gear.
    i already using batteries for dampening.

    when i mount my copter indoor and move it in small angles i get about 0.04 error in roll and pitch but 0.2 - 0.6 in yaw axis. i tried a lot pid settings

    Which resolution do you guys get in yaw axis?


    Made a short test with IMU above Yaw motor! Sucess :-)

    I thought the smaller error showing in BGC Gui would clean the problem out. But shaking is still there.
    The best setting so far was 10 - 0.01 30 235
  • what is your yaw motor? size, number of poles? What gimbal are you using?

    What do you have the deadband of yaw set at? Add deadband to see if that helps. You may have deadband at 0 and its actually trying to stay at 0 degress and fighting itself