EN RU CN
Error Checking Latest Versions
  • Hi,

    When checking for the latest firmware I get a message saying:

    Error Checking latest versions: java.lang.exception: Error sending http request: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    I can't upgrade in manual mode. Any thoughts on what is causing this?
  • I am having the same problem. Do they have a direct download for the firmware?
  • I couldn't find a direct download. If anybody knows of one, that would be great.
  • It appears to be a certificate issue and Java will not allow it to connect to the site to check for software. My gimbal is currently dead in the water until I can check for an upgrade or manually get a firmware file.
  • Same problem here, and i need this gimbal to start working, can someone find solution for this ?
  • I tried to write some earlier version of firmware and it works, but now software says LICENCE IS NOT VALID
  • I was not able to write any previous versions of the software and have it successfully work.
  • They updated something. I was able to successfully check for new firmware and upgrade the controller to 2.50 b2. Back to working gimbal now.
  • It was an error with SSL certificate. Now the error is fixed.
  • Hi,
    I'm using 2.50b3 and still get an java error while checking latest version:
    'Error checking latets version: java.lang.exception: this device is not activated. Please call support service for help.

    Any ideas how to fix it?
  • And its not a problem with my computer, I've updated already to latest version 2 other 32Bit AlexMos boards with my computer. I also tried with a different computer. I bought the board at Flyduino.
  • Looks like the same problem is happening again for me. Can anyone confirm this?