EN RU CN
Bad soldering
  • Can someone confirm this is a bad soldering. I can't get my gimbal controller to work and I keep blowing up IMU sensors. I think it goes wrong on the main board.
    https://dyp.im/Ckt1HTl0lR
    https://dyp.im/M6r450yQ71
  • To bad no one can give me an answer. To give more info, the pitch an roll are working good, but the YAW isn't working. I made a video, what will show you what happens when switching the YAW board on in the GUI. Link:


    I tried all PID settings, Power settings etc, all with the same result, YAW movement is irregular and rapid all over the place. I have no idea why, I think because the board is broken, or because of the bad soldering on the main board.
  • Hello! The setup with the second YAW board is a bit tricky. Try to decrease P, I, D to minimal. Try to change Invert settings. Disable FOLLOW MODE.

    Checking that hardware is ok, is simple: remove motor from gimbal, set I=0.01 and turn sensor from original position. Motor starts to rotate. If wrong winding or one on 3 phase is broken, it will jerk.
  • Thanks Alex for your response and your super great controller, I did all what you advised already. I tried your last tip also and the motor didn't turn slowly (in pitch and roll it worked fine) and when hooked on to the YAW board it started to jerk. It was the ROLL motor I tried so I knew that motor was good. I'm pretty sure something is wrong on the board. Did you see the soldering on the main board? Could that bridge connection on that chip could make this problem? I got the YAW board from funtobuyonline.com and there board looks different than all the other boards. I now ordered a new YAW board from Flyduino because funtobuyonline.com doesn't respond to my questions. They offer good price, but horrible service. Hopefully this new info will give you more an idea what the problem is?
  • Video of the YAW error

  • Hello! From this video, it is cleary that YAW board misses one phase. Try to contact the seller giving link to this forum, to exchange the board. Or, you may look closely on every joints, may be you will find soldering error.
  • Thanks, but will the error be in the 3rd axil board, or in the mainboard? I tried a second 3rd axil board from fluidino, but that one didn't work also (no sensor was detected).
  • If LED on 3rd axis board is blinking, main board is working (sending data). Error is in the FETs part of the board.
  • Thanks! I know enough!
  • I have the same problem as described in this post:

    http://forum.basecamelectronics.com/index.php?p=/discussion/489/the-yaw-axis-does-not-work-#Item_2

    I checked all the solder and they all look well done, I can not solve, the yaw does not work ... :-(
  • Hi, and thanks for the great work... in regards to the statement, ...

    "Checking that hardware is ok, is simple: remove motor from gimbal, set I=0.01 and turn sensor from original position. Motor starts to rotate. If wrong winding or one on 3 phase is broken, it will jerk."

    I am having zero success with my YAW and have completed the test below and get nothing but jerks...on three different motors.
    all the same style - motor link http://www.gothelirc.com/images/motors/ipower/GMB5108-01.jpg

    Is it possible all three motors are incorrect, or maybe the 3rd axis board is incorrect? Any suggestions?

    Thanks!
    scott
  • Does it look like what happens in my video? If so, then the 3rd axis board is broken. Ask your seller to send you a new one.
  • Thanks mbprod,

    I would say it's similar...not as erratic. Did a new 3rd axis board solve your issue?

    Pitch and roll have been removed from test video (slow upload) at http://youtu.be/USU7zXTC4EI
  • Hi,

    well it looks like the same error I got. When I got the new board, all problems where gone. What board did you get? The first board they send me looked like this:

    http://www.fpvmodel.com/img/SBGC3rd/SBGC3rd01.jpg

    I think all these boards are bad, because they've been all taken of the marked. When I received the new board, I got this one:

    http://aerialpixels.com/wp-content/uploads/2013/08/AlexMos_3rd_Axis.jpg

    I hope this helps!
  • I have the newer board that you have, I just RMA'd it to the seller who will test it to determine hardware v user error. Hopefully working after. Thanks for the advise and I'll post followup later this weekend.
  • I know this is an old post, but I am having problems with the 3rd axis board, which is the older (bad?) one shown. Random spikes and twitches on the YAW mostly. Did the new board solve the problem for you? Thanks in advance.
  • Hi Moosefuel, yes it solved all my problems. As I remember correctly, there was a design error in that old board. They should not be on the market anymore. I hope this helped.