EN RU CN
Roll gets unstable when pitch is 90 degree up or down
  • Someone else had similar issue which I'm having with 2-axis gimbal. Discussion did end before reason for this was found and therefore I post this problem again.

    My 2-axis Gimbal works just fine in hand and when controlled via RC In range of +80 to -80 degrees. But Roll axis gets very unstable and begins to swing around when Pitch angle is +90 or -90 degrees. Instability of Roll axis begins from about 84 degrees. or -84 degrees respectively. When Pitch is driven over -110° and +110° Roll gets steady again.
    Details I think might be helpful are following and I provide anything needed more:
    - FW 2.66 b0 latest attempt
    - FW 2.63 b0 earlier attempt
    - All settings returned to default and only mandatory settings are applied (RC - main PIDs - Orientation of sensor - 6 pos - 12 poles)
    - 6 - pos calibration is done
    - Board is new official from Basecam with encoder support. Encoders are not is use. FW is for without encoders.
    - Camera is very well balanced and it stays where is when motors are powered off
    - Motors are T-Motor GB4106
    - Camera is Canon EOS M with Canon 22m f2.0
    - IMU sensor is mounted with M3 screws to laser cut holes of camera stand and is very well aligned
    - Settings file, a video and screenshots are here: https://tinyurl.com/y7tafovj

    Pole count 12 I'm not 100% sure because I didn't find any good source for it but one site told it is 12. Auto detect gives very random results.

    Could someone help me to find reason for this or could this possibly be FW issue.
  • Hi Teppo,

    usually motors don't have 12 poles but 14. Try to set 14 poles and try again. AUTO function doesn't give correct number of poles everytime.
    btw, if you not use encoders, do you use frame sensor? If not that can be source of your problems.
  • See the euler angles and there is couple of options for 2 axis setups under stabilisation (att the bottom of the page) test them.
  • Thanks for replies! I try these in the evening. I Googled again and found another site where is said like this:
    - "No. of Stator Arms (N) 12No. of Stator Poles (P) 14"
    - Another site said "12/14 poles"

    So at least pole count seems to be wrong.
  • I changed pole count to 14 and it didn't help. I also tried Euler angles and stabilization for 1-2 axis systems settings without luck either. According to manual those shouldn't make any difference in this case because this gimbal works just perfectly on all other angles but mapping angle and directly up. These settings made gimbal not working correctly on any angle, or didn't make any difference.

    Gimbal works flawlessly otherwise but "mapping angle" do not work for some reason.
  • I did the same, install the software 2.60 and it was solved. But, I would like to know what the inconvenience is.

    Greetings.
  • @Ariellago, 2.60b4 without encoders worked, thank you!
    I'll post this info for support because I've been asked more detailed videos of the problem and therefore this isn't known bug.
  • Any updates on this please?

    I have a very similar setup as the OP with the BCG32Extended board and no encoders, and the same T-Motor systems.

    Pitching down >75deg causes instability. Pitch down 45deg and tilt the frame >30 deg and the instability happens as well. So there is no way for the gimbal to face 90deg downwards. When the system is oscillating violently, pitching back up past 75deg allows the system to stabilize.

    IMU is CANbus under the camera. The main IMU is above the yaw motor (frame).

    Firmware is 2.66 b3
  • I have to add that I am experiencing the same issue here.
    Gimbal is well balanced and performs flawlessly until the camera is tilted down past 80 deg.
    Then the roll just goes ballistic and slams the camera against the ens stops for roll.
    Pitch the camera back up to horizontal and the gimbal performs flawlessly.
    Has anyone found a solution or even a cause for this?
    Would hate to have to ditch the gimbal and install another.
  • "Solution" is found but not cause. Solution is older firmware described just above these comments.
  • Hi, I do also stil have exactly the same problem. 2 axis gimbal with encoders, precisely cnc manufactured gimbal, so imu position is fine. The camera is stabilizing+15 degree over horizon and -90 degree (mapping position, looking exactly down). When the camera is moving to more than 80° down, the system gets unstable and Roll is shaking. Any suggestion please?
  • I'm having the same problem on Encoder enabled firmware (Up to 2.68 b6).
    I've disabled YAW for now, but Roll axis compensation seems to be reversed for Pitch angles >90 or <-90. What I mean is that I not only see an obvious instability around 90, but the correction that the controller is trying to apply for the Roll motor is reversed, meaning it's trying to pull it away from the target angle.<br />
    The only solution I've found is to go back to a non encoder firmware.

    My encoders are AS5048B.

    Has anybody managed to get encoders working with this board? I'm sure it can be my fault, but I'm seeing lots of similar posts with no solution since September 2017 and I find it strange that this bug has gone unnoticed for so long.
  • Hello,
    Thank you for reporting this issue. We will check it before the next firmware release. I will let you know about the results.
    Please, share your settings for the gimbal saved to a file, it will be helpful to find the problem.