Gimbal Beholder (Ikan) DS1 - Motors wont start anymore, only green light turns on
  • I have been using gimbal Beholder DS1 for 5 years and it always worked perfectly.
    Last time while it was in my bag I just wanted to check if the battery is in it, so I quickly turned it on to see if the green light comes on, and in 1 sec I pressed it again to turn it off.

    From that time on, the gimbal's motors won't start anymore.

    When I turn it on, just the green light shows up and motors won't turn on.

    I also connected it to SimpleBGC software and it recognizes the movements of motors, but I can't make motors to turn on.

    Is there any way to hard reset the gimbal?

    I tried to press all the buttons it has on it and I can't find any solution of how to reset it or make the motors work again.

    Here is also the video explaining the issue:


    Do you have any ideas or suggestions of how could I reset it all or what happened?
  • hello have you solved?
    if yes I ask you for help it is more than 3 months that my gimbal ds2 beholder ikan is stopped because the motors do not give any input how can I fix a hand thanks