Yaw motor slowly rotating to the right when motors are powered.
  • I am fairly new to the brushless gimbal world but i have been having a persistent issue with my handheld dys gimbal. As soon as the yaw motor has any pid settings the gimbal frame starts to slowly rotate to the right. it can rotate 180 degrees within 20 seconds. i have changed imu cables, i have changed the boards and the yaw motor twice, but the drift to the right still persist. there is no active rc inputs and the sub trims are at 0. putting some ferrite rings solved issue for a short time until i decided to clean up the wires by running them back through the gimbal frame then the slow rotation to the right came back. what exactly is causing this issue. i have calibrated gyro and acc multiple times as precise as human error would allow without any movement. i have had this gimbal over 5 months and have not been able to use due to this issue.

    mots are BGM 5208-200-12
    32 bit alexmos controller
    dys eagle eye gimbal frame.
  • Do you have analogue joystick, if yes, you need to calibrate it.

    Motors or the boar will not cause the drifting. You could have faulty IMU. More likely it seems problems with i2c communication. Run the i2c cables separate of the other cables. Are you using some inverter or some other electrical noise source?

    It is important the the gimbal is immobile during the gyro calibration. Just but it on floor when performing the gyro calibration, it does not need to be well leveled, just stabile. (but failing to do this right will not cause 180 degree in 20 s drift.)
  • i have tried 3 boards and used the same imu cables that came with them, all of them gave me the same persistent rotation to the right. when i do gyro and acc calibration i take the board off the gimbal to avoid the movement during calib..i do not have a joystick connected. i have only gotten this to stop once by adding some ferrites but after thinking i figured the issue out i re positioned my wires to clean up the look of the gimbal and even with the ferrites my drift has returned. i am also now having 12c errors when pitch motor is connected. i assume this is from me unplugging and re plugging connections to find my solution to the first problem. how do i run 12c cables separate? i am not using any inverters or any other electrical noise sources. just the gimbal the board 3 motors a 4s lipo battery and few ferrite rings.
  • You have too many things going on, I can only repeat what I said above and fir the I2C problems fist before trying anything else.