Getting IR Shutter to Trigger from Ardunio
  • The following device is installed on AlexMos32

    Color:Black + red + white
    Compatible device:RC helicopter
    Aerial photography
    Switch your camera between photo mode and video recording mode using your transmitter (using a 3-position switch);
    You can also control start and stop recording under video mode;
    Cable length: 51.5cm;
    Weight: 5.5g;
    The control channel should be a 3-position switch channel;
    Hint: For WFLY transmitters, no setting is needed for the 3-band switch, if you use Futaba T8FG / 10C / 12FG / 14FG;
    Transmitter, you need to set the "END POINT" parameters to "135, 100, 110, 135";
    Operating method: Let's mark the 3 positions of the switch channel of your transmitter using position 1, 2 and 3, when the switch is set to position 2 (middle position) then camera stop working, when switch is set to position 1 or 3, then the camera will work in continuous photographing mode or video recording mode, video recording will start 2 seconds after the switch is turned to the video mode position;
    If position 3 is for video recording, to stop recording, you can turn the switch back to position 1, now the video recording will not stop, then you can move the switch to position 2 (middle position), then video recording will now stop

    The device is installed on FC_ROLL with white on the outside pin signal. Red is the middle. Black is the inside pin ground. Connected via Blue tooth.

    When trying the code approach using the MimicControl example with the relevant settings show here:

    // PWM output port index
    #define PWM_SERVO_OUT_IDX 0 // 0=FC_ROLL, 1=FC_PITCH, 2=RC_PITCH, 3=AUX1

    // PWM values for external infra-red camera control adapter
    #define PWM_CAM_REC_ON 2000
    #define PWM_CAM_REC_OFF 1000

    //command to trigger servo
    cmd_servo_out.servo[PWM_SERVO_OUT_IDX] = PWM_CAM_REC_ON;

    Nothing happens.

    I can move the gimbal with the program not getting it to send IR flash to camera.

    I have also tried using the script commands in the GUI they accept but no trigger.

    SERVO 1(1500)

    Tried 100,135,1000,1500,2000

    Any ideas? Do I need to set something in the GUI in the RC section?