YAW axis spinning continuously and red dot on SimpleBCG GUI Yaw axis going crazy
  • Hello,

    I have recently bought my first Gimbal for a DIY project. The gimbal is a "Handheld 3-Axis Camera Brushless Gimbal for Canon 5D2 Kit W/ 3x Motors", and the Alexmos is a "Alexmos BaseCam Simple BGC3.0 SBGC V3.0 32-bit 3-axis Brushless Gimbal Controller w/ 2nd IMU | official version V3.0". I bought this on an online store; I can provide links if useful and not contrary to forum policy.

    I am experiencing strange problems on the YAW axis setup, but the PITCH and ROLL are working.

    There are two major symptoms:

    1. The red dot in the YAW axis in the control panel in the right side of the SimpleBCG GUI keeps spinning randomly at high speed when the motors are turned off (see short video here:
    2. If I turn on the motors, the red dot stop spinning like crazy, and it locks with the blue arrow. However, the gimbal keeps to rotate counter-clockwise without stopping: it takes approx 20 seconds to rotate a full 360 degrees. I have to stop it by hand to prevent it to rip the cables. Fortunately I have kept the P and POWER values for the motor to values that will not rip the cables apart at this point.

    I think I have understood the basic functioning of the device, the PID settings are clear (I have an engineering background), but I have a feeling that the problem is specifically with the YAW axis at the hardware level, as the two other axis seem to work well.

    I have read several posts regarding the YAW axis and the fact that it seems that some boards are defective or have intermitting problems with the yaw. My board never worked in the YAW axis correctly.

    I would like to know how to assert if the board is defective (i.e. bad connection with the 3rd axis board?) or what to do to solve this problem. I have spent a long time assuming my lack of experience was the problem but after trying every possible tutorial and option I am reaching the conclusion that the board is defective.

    Can you please help me address this issue?

    Thanks in advance and greetings from Italy.
  • What does the Real time tab show for yaw gyro?

    I would suggest disactivating the gyro calibration at start and doing it manually. when doing it making absolutely sure nothing moves, i.e the gimbal is steadily on steady floor etc. The axis positions do not mater, but it has to be still.

    More likely than the board it is the IMU, if something is broken.
  • Did you figure this out? I am having a similar issue
  • has there been any insight to this issue? same problem,my IMU's seem to be working fine just a constant spin of the red dot. my blue IMU arrow starts following it as soon as i put power to the motors.
  • If it helps, I had similar problems... I pulled the IMU cables from inside the tubes and added two ferrite rings around the cables near the board, which I bought off of Amazon and it seems to have corrected the problem for me, at least at this point. At one point I had both the Roll and Compass spinning wildly around... it seems to have fixed my problem for now
  • I had the same issue and my case it was related to the joystick. To verify if it's the same situation also in your case, just disable ("no input") the yaw axis in the "RC" tab.
    In my case i solved it by raising the "Deadband around center" value from the default 15 to 18 in the "RC Sub-trim" section of the "RC" tab.

    Hope this helps.
  • I had a similar issue, though it would happen with all three dials. Turns out i have a bad cable and there is a bad connection with the IMU.

    Is the green light on one of the sensors flickering or switching off during power on ? The connections on the sensors seem quite sensitive, especially if the gimbal accidendally tugs a cable.

    Perhaps you should isolate the problem by only plugging one IMU at a time, testing each IMU and cable seperately. This is how I narrowed my problem down to the faulty cable. Also make sure gyro/acc is calibrated properly, with no motion at all. To do this i took my alexmos out of my gimbal and attached the sensor to a plexiglas cube to get six stable 90° angles. Good luck !
  • I'm using 3 axis gimbal with flycat 2805 140kv motor for yaw and 2204 260kv for picth and roll, with Simple bgc tiny ver C. Only one camera IMU is placed.
    In latest firmware everything was working fine but when pitch is given below 60 deg (looking down ) the gimbal becomes unstable.
    So I changed the firmware to 2.60b4 as suggested in this forum. thing were fine but after some time the yaw error builds up and becomes unstable only in yaw axis

    Now I'm facing exactly the same issue as in this thread and I've done the above and checked everything. But Still face the same issue.
    I need RC input for my setup mainly for pitch axis and Yaw axis.

    Help me out Guys