Upgraded firmware new problem locked up board
  • 8 Bit board, now balanced for different camera, upgraded firmware and GUI to latest. (haven't been working on this for several months, now I need it for a shoot!!).
    All seems ok in GUI, I can make and write changes, watch the real time IMU responses etc but as soon as I switch on the main battery power the GUI realtime display locks up and I can no longer communicate with the board, it doesn't give me any error just locks up, the green and red LED on the board are steady on.
    I have tried rolling back the firmware but no change.
    I have matched the version of GUI with each Firmware version I have tried using.
    If I switch off and on again the gimbal goes through it's normal startip process, seems to calibrate, the motors engage for about 1 second then it stops, the motors disengage and it sits there, dead but with LED's on.
    Battery is fully charged 4S as used previously.
    I have run the gimbal in the past with no problems in all modes including joystick.
    Any assistance is appreciated.

    Thinking about going to the 32 bit board, but I am already on my second 8bit board and the cost is rising!!
  • I think I may have discovered the problem, I took things slowly back to basics, disconnected everything. On removing the joystick connections and powering back on all came good and it no longer locks up. I believe it may be due to the existing (old) joystick settings which I need to redo.