EN RU CN
Values for compass, roll and tilt "rolling" in GUI
  • I have a 2 axis gimbal with a Neewer control board running firmware 2.0. My problems initially started when I shorted a wire hooking up pitch control to my DjI Phantom, killing the control board and also my flight controller. I replaced both and then immediately crashed my Phantom, tarring up the 2nd control board. So now I am on board #3 and I am having a problem I just can not figure out. No matter how many times I calibrate the ACC I keep getting a ton of I2C errors and all 3 "gauges" in the GUI just roll around their values, as if the gimbal was spinning. I have 3 different sensor boards now and have tried all 3 and 3 different cables with the same result on all 3. This of course causes my gimbal to go nuts. I also had this problem with the 2nd board that I had, but attributed it to the crash.

    I am really at a loss. I've tried updating the firmware through several different means but none of them seem to work (GUi gives an AVRdude error, AVR Tools on Mac seems to load it but GUI still reports same firmware version, Xloader on Windows won't even start, and AVRDudeR gets no results).

    I am to the point of just getting a new gimbal altogether but hate to do that if this one can be salvaged.
  • Are you sure you have selected the direction of X, Y, Z as the IMU is installed?

    Though that would not cause I2C errors, ACC calibration will not affect I2C errors either.
    What does the realtime display show?

    Maybe motor is broken causing electrical noise and errors to I2C, but more likely the board. If you disconnect the motors, do you still get I2C errors?

    How have you powered the board, is the power ok?

    First priority would be fixing the I2C errors, i.e. finding the reason for them.

    Really bad electrical noise could cause problems also with the firmware update, especially if the USB cable is long and not well shielded i.e. low quality cable. If you disconnect motors and power and use good quality short cable, does the FW update work?
  • I believe I have it all set up correctly as far as the XYZ information goes.

    The power comes from the accessory output on the Phantom, I have always had it powered this way.

    I disconnected the motors and the power lead from the Phantom and just powered it from USB. Doing this stopped the Roll and Pitch readings from "rolling" but the compass reading still seems to do it. I was still not able to upgrade firmware but I assume that it is due to this being a no-name board. Also stopped getting I2C errors when I did this.

    Anyway, does this point at one of the motors being bad and putting out some sort of electromagnetic interference that is screwing with the sensors?

    Also how hard are the motors to replace once I get replacements?
  • Well I don't know what I did exactly but now it is working fine!
  • Maybe some insulation of the motor wires has been damaged and occasionally, depending of the wire position it touches the metallic parts of the motor. If this happens just in one place, it could cause interference, if in many places even a short circuit.