EN RU CN
Firmware Update Failed... Gimbal no longer connects to computer.
  • So, I've been through every other troubleshooting post, and none seem to apply to my situation, or have an answer.

    Recently bought an AlexMos Brushless Gimbal for use on commercial film sets. It was bought thirdhand from a fellow filmmaker who bought it secondhand, but I am the first to encounter an issue.

    The board is labeled as an SBGC v3.0. There is a bluetooth module attached inside.

    The Gimbal was working perfectly for several weeks, but we recently upgraded to a heavier camera, and the gimbal was struggling slightly. I decided to try updating the firmware. I downloaded SimpleBGC 2.63b0 and updated the firmware.

    The gimbal immediately began to twitch and jerk randomly, which nearly caused damage to the camera we had mounted. I powered down the gimbal, and tried to troubleshoot. The axes sensors seemed to think the gimbal was off-axis by quite a large margin, so I clicked something to reset them.
    The gimbal went limp, and a warning appeared stating that the accelerator was not set.
    I looked extensively, but could not find the button to set it. I now know that 2.63b0 doesn't have that button, but at the time it was confusing.

    I attempted to downgrade to 2.60b4, and downgrade the firmware accordingly.
    The firmware update failed, and the gimbal stopped communicating with the computer.
    All further attempts to communicate with the board have failed.


    Error messages I get:
    Error upgrading firmware: Error writing firmware: Flash tool execution failed (1)!
    Error upgrading firmware: Error writing firmware: Timeout!
    Error upgrading firmware: Error writing firmware: [1] avrdude: stk500_getsync(): not in sync: resp=0x00


    We have tried multiple USB cables, we have tried flashing through bluetooth (computers can't see the bluetooth module, even though it is powered and blinking on the board).
    When plugged in via USB, the COM3 port becomes available in SimpleBGC, but no data can be sent or received. We have tried multiple previous versions of SimpleBCG, still no luck.


    The board's serial number was lost when the board stopped responding. I should have written it down, obviously, but I didn't think of it at the time.

    Please note that I am not a technician, I am a videographer who knows little about this device. I am simply concerned that I have managed to destroy a $1200 gimbal only weeks before it's needed on-set.

    Any help would be appreciated.

  • If it is "bricked" and needs to be replaced, how difficult/expensive is that process? At a bit of a loss here.
  • Hi,
    sorry to ask without any answer to your question but I was just wondering if you had a solution to your problem… I have a similar one… Thanks if you have time to answer.
    best regards
    Samuel