EN RU CN
Yaw won't turn past certain point, twiching and shaking.
  • Hi everyone,

    My problem is with the yaw axis (3-axis 32bit AlexMoss board). I've looked through the forum and nothing quite matches the issue I'm experiencing...

    Settings are: PIDs (r25, 0.7, 55; p12, 0.5, 25; y30, 0.3, 45), power (r100, p150, y170) number of poles (18). Follow yaw is off.

    Yaw has no limiting settings but there is a point in it's travel that it stops and bounces back, as if the gimbal had hit something; it then judders around that point until I tell it to come back to neutral. It won't go past that point. This happens in both directions from neutral, and none of the settings seem to make any difference. I've re-calibrated the PIDs and power so many times I've lost count :) The min/max angle settings are 0, so why is it stopping? I've posted a video (650mb, 10min) at

    https://www.dropbox.com/s/awg15igfo02zjf3/Kryss Eamer001.mp4?dl=0

    I've sent a query to the Support section but haven't heard back yet... If anyone has any suggestions I'd be very grateful, I've been stuck with this for months.

    Fairfarren,
    Kryssie
  • Sounds like problems on basic setup.
  • Thanks for your reply, Garug. Can you be specific, though - what do you suggest?
  • Performing the basic setup exactly per users manual. Your motor pole numbers sound suspicious. Is that from motor specifications? have you performed successfully the Motors Auto etc. but it all clears out if you follow the users manual exactly.

    If it does not work after that, it could be broken motor, but not likely, that would have also other symptoms.

    I can not see the video, loading it to Youtube would be better.
  • You mentioned that you didn't SEE any wires getting caught up when it turns, but have you tried turning off the motors and physically moving it past these points that it bounces off of? It doesn't take a ton of extra physical resistance to cause motion that might resemble that. Make sure it doesn't take any additional force to pass those points.

    Just a thought.
  • When the power is off the yaw axis moves 180 both directions without fowling on the landing gear or wires, no extra force anywhere is required. From what I can remember when I did auto motor pole calibration the software turned up different numbers for each motor, even though they are all the same (circumstances prevent me from trying auto pole calibration right now).
    These are the motors that came with the gimbal:
    http://www.dys.hk/ProductShow.asp?ID=18
    I just noticed it says Camera Range 500grams, what happens if the weight exceeds that? The yaw motor carries my camera at about 900grams, plus the gimbal and wiring. Could it be stressing the motor's capabilities?
  • Those motors are 24 poles.

    If you will try to control the gimbal with higher acceleration than the motors can provide, the motors will loose synch, with mush the symptoms you describe. I assume this is non encoder gimbal.

    Try using acceleration limit and RC control LPF and control with slow moves, like when filming.
  • Thanks, I've changed the pole count to 24.
    LPF is 5, I tried others but it makes no difference, still stops at the same two points in the axis. The movement is quite slow anyway, speed setting is 10.
    I just did the auto pole number count -- pitch 24, roll 27, yaw 31. Something tells me that's not correct :)

    Another confusing thing that happened this morning -- connected the controller to the computer and a warning in the software "12C censor not found". The IMU wires are clearly not broken, the solders and holding and when I tested each wire from the board to the two IMUs for continuity, all the wires are OK. I tried again and the connection registered, but the 12C errors climbed continuously (over 1800 in a few seconds). More fiddling around with the wires, tried again -- it worked! So now I think there is a faulty connection in the IMU/12C wiring as well; great :/
  • Yay, the yaw rotation is fixed! The wires running through the yaw arm and up to the UAV body were just stiff enough to inhibit the yaw's turn without appearing to, and not enough to notice when I turn it by hand. Pulling the wires to allow more slack has reduced the resistance and the yaw turns as per the settings.
    So now I can change the title of this discussion to "IMU censor no recognized", because that is still acting up.
  • You must change the poles manually to actual motor pole count. You must fix the I2C errors. Route IMU cable separately from other cables.
  • Check connectors, they can be loose.
    If connectors are not causing these problems then use Garug's suggestion and also use additional ferrite rings on motor and IMU wires.
  • The 12C errors have only appeared once, and that was the time detailed above. I've never had them before that, but I will definitely use the Ferrite rings (when they eventually arrive, long postage time where I live). The IMU cable seems to be OK now, all the plugs are secure; after some fine tuning maybe time for a flight test...