EN RU CN
Beholder DS1 not power on
  • One day while using DS1, it stopped working sudenly, so I thought batteries were empty. But with batteries fully charged, beholder doesn't power on anymore when pressing the button. I bought a new battery holder because I realised it had a burnt component. But with the new battery holder, it still doesn't turn on. When I conect it to SimpleBGC_GUI, it connects perfectly and the software indicates the position of the motors fine, but it indicates batteries are 0.0v (although they are fully charged). And if I click on "motors on", it doesn't power on (but If I press the button on the DS1 constantly, the battery indicator of the sofware moves slightly). So what can I do?

    PD: sorry for my bad english.
  • see battery calibration.
  • I have tried it, but nothing happens, battery level is still shown as 0.0. If I press the DS1 power button, the software tells me "LOW BATTERY LEVEL, battery is near empty", although they are fully charged.
  • Then disable the low battery level warning and see if that is the problem.

    How do you know the battery is charged? 0.0 colts sounds though battery power is not coming to board. Bad wiring, switch etc. I would contact the gimbal manufacturer or seller, they should be able to support you.
  • I tried it and nothing happens. Batteries are charged, I used a Vom and voltage was OK. I also opened the DS1 and checked wiring with the Vom, and everything was Ok. And If I unplug the power cable from the board, the green led of the power button turns on when pressing it, like if DS1 was turned on. If the cable is connected to the board, the DS1 doesn't turn on, as I said. But now that DS1 is open I realised that although DS1 doesn't turn on, a small red light blinks in the board every time I press the power button. I also checked with Vom the cable that connects battery and board, and it's Ok.
  • Nor any component seems to be burned.
  • I had maybe an similar issue. After charging DS1 didn't start. I removed the cap and pushed the battery holder with more pressure than the cap was going to do.
    The green light powered on and the gimbal started to calibrate. After that I several sheets of paper between the battery holder and the screw cap.
  • I have the same problem with my BeholderDS1 . And have no answers...
  • This happened to me before. I didn't know how to handle the prob so I just didn't use it anymore.