EN RU CN
2.50b is it all becoming way too complicated??
  • Even though I appreciate Basecam team their effort to improve and inovate I sometimes wonder if it is not becoming as my title say. I am happy with the way my gimbal works with 2.49b, it has taken me a long time to fine tune it hence I am somewhow reluctant to upgrade to the latest version and spend hours ploughing through the added benefits. Am I the only one one feeling like this?
  • I have some gimbals still running 2.44 and even older, if it is working and performing well, why to upgrade.

    At the same time I am testing constantly latest FW on some of the gimbals and indeed, sometimes it takes time to get everything working reliably. I would not upgrade FW just before important shoot etc. at least some days are needed to test that everything (including tuning and setting up the gimbal) is working reliably.

    Things like filtering or advanced RC settings, scripting etc. makes it look more complicated, but at the same time they can be very useful. Encoders make it yet more complicated, but those settings normally need to be touched only during the first setup. There is some parameters that are not used at all in many setups, there are parameters that are not used after first setup and some of the parameters need to be frequently accessed when changing camera etc. I hope the GUI would be better organized, but at the same time I am used to it and generally resist any changes.... but I think the GUI would need an upgrade and I do not much like the Java, causing all the time problems.

  • I have updated to version 2.50b3 and I had problems on the imu, not recognized well, in fact if they moved quickly, the basecamp crashed.
    I then decided to downgrade the version 2.40b8 I had before, after that I had the red LED on steady and the card does not do anything more.
    I also tried to load another firmware with bcg and xloader but does not accept it always gives me error.
    How can I fix?
    thanks
  • how you tried disabling acceleration temperature calibration. From my knowledge, it came on as default when we upgrade from 2.43b9.

    And 2.40b8 is for 8bit, 2.50b3 is for 32bit. you could have bricked your board.