EN RU CN
PWM RC_ROLL & RC_PITCH now working
  • Hello Everyone!

    I'm facing strange issue. I have four RC inputs on BGC board. Two for RC inputs ang two for FC inputs. RC_ROLL and RC_PITCH stopped working. To control gimball I have to use EXT_ROLL and EXT_PITCH. Signal is PWM.

    I had little crash landing, but copter and gimball seems to be okey. Everything is working fine despite of those two RC inputs. Do You have any sugestions? I tried to reflash firmware but with no effect.

    I'll be grateful for help.

    Regards,
    Thomas
  • Put here a couple of controller's detailed photos.
  • Nobody has any idea what could couse such strange issue? :(

    The only functionality of RC_ROLL that works is analog input.
  • I'd also like to know the solution. I have the same problem, although on my board none of the pins seem to be carrying the signal. I've verified PWM output from my pixhawk using a servo. And also verified the correct Signal and ground wires are connected. I've been through all the possible assignments It worked before but for some reason just quit on me. Did I possibly brown out part of the board? I'm very inexperienced so sorry for the panic!
  • Realtime data also shows no signal. (although I know its being outputted from pixhawk). Also, it seems, I cannot set pitch offset. Pretty sure this was working before.
  • I have the same issue and just now I noticed there is another thread about the same problem I have, I also made a video with my issue, I have tried before to connect the receiver to those ports, after I couldn't make it work tried the servo tester, didn't worked either, that tried the special remote I purchased from RC Timer .. din't work ... the only thing that partialy works is an analog joystick, but the value only drops from ~2000 to ~1700, and only for the PITCH, the value from the ROLL doesn't move but it shows a low value, like 1200.

    Right now came back from another friend that has an 32bit board and a joystick, I connected hi joystick and it acted the same as with mine.

    I don;t know if it's a hardware problem or something related to software and settings.



    PS. If a moderator sees this message, maybe you can delete my separate thread I started today.
  • I just ordered a new controller as I need the gimbal at the end of the week, if anyone can give me some tips if I can make the old controller work I'll appreciate any reply.

    I found some more weird things, if I setup the input pins as ANALOG, all the pins as analog and I plug in ONLY ONE pin, let's say RC_ROLL, when I move to realtime tab in the software,ALL the values change like the RC_ROLL, with only one pin connected !!!

    PS. in the meantime I will try to connect an bluetooth module and see if I can control it using bluetooth, if this work than I'll have another chance by using an atmega 328 to convert the PWM signal from Receiver and send them to the blueetooth module. But I realy hope thee are other ways to fix the problem..
  • I'm having the same issue, but with just the RC_Roll signal terminal. I AM getting power from RC_Roll, but no signal.

    Previously I was not getting power from RC_Yaw, so I checked the board and found a bad solder on the ground terminal. I re-soldered it myself, and it is now working.

    I've tried the same for the signal post on the RC_Roll, but to no avail.

    Anyone out there solve this yet?