EN RU CN
calibrating imu's Having major problems NEED HELP ASAP!
  • I have a 3axis gimbal running on v2.43 b9. I have been using it with great pleasure the last month. Yesterday it started to freak out when I would turn it on. I looked at all the specs and I had to recalibrate the accelerometer both camera IMU and Frame IMU. I redid the 6 point calibration for the camera IMU and I have all check marks, For the frame IMU it wont allow me to click the button. I am very new to this stuff and I need to get this piece of equipment up and running and I have no idea what to do. The red dots are all over the place for my Pitch, roll and Yaw meters. Is it normal for all the info in the accelerometer to disappear? I have been looking online for the answer but I cant find a thing. I have reworded my search to any and everything I can think of. I am in desperate need of help. Please if someone can tell me how to fix this I would be beyond thankful.
  • Have you activated the Frame-IMU ?
    You can find this option in the GUI by Advanced -> Sensor.

    A other thing what can happen, is that your Frame-IMU is using the same I2C address as your Camera-IMU !
    Please read the manual carefully how to do this.

    Regards,
    Marten
  • I have the frame IMU activated but I still dont have access to calibrate it.

    Any other suggestions?
  • Have you try disconnecting frame IMU and work only with camera IMU?
  • Again...
    Have you checked your I2C address from your Frame-IMU board ?

    Have you a link or some pictures/video from your IMU's and controller ?
  • I think I am having the same issue... See video. I checked that Frame IMU is active. It says "12C pullups enable" Which I think means its on?

  • Is your GUI and FW version the same?
  • Thanks for your reply!

    So I not exactly sure how to check that. I have the latest FW installed 2.43 b9 how do you check the GUI? I just downloaded the newest GUI but Im not 100% sure... When I click about SimpleBGC I see that is says version 1.0(1.0) weird...
  • wait... I think I found it. it says the GUI is 2.44 b9...so they don't match... So I need to download a old GUI so they match?
  • Update.... That fixed it completely. So GUI and FW defiantly have to match.... Thanks for the help!!!