32bit controller does not level camera at startup
  • I recently built a new gimbal (Dys Eagle Eye) with a 32bit controller and two IMUs. For the most part, I've been able to tune the 32bit board quite well and it operates the gimbal smoothly. However, there are two nuisance problems that I just don't seem to be able to figure out and that I have not encountered with my old 8bit controller.

    1) When I power the 32bit controller up, it doesn't level the camera. Instead, the camera tilts right and forward in about 20 degree angle (my old 8bit controller levels the camera perfectly at startup). I can level the camera with the joystick after startup but it is annoying to have to do every single time.

    2) When I roll the gimbal to the left, the camera does not remain level but hangs to the right (in an angle that seems proportional to the frame's roll angle, i.e. the more I roll the gimbal to the left, the more the camera leans to the right). When I tilt the frame to the right the camera leans to the left. The yaw remains solidly locked during all this.

    I've not been able to find any adjustments that would help with the above startup leveling and roll overcorrection problems. I have calibrated the IMUs a number of times and checked and rechecked that they are perfectly aligned. I would therefore very much appreciate any and all advice!
  • Make sure the IMUs are well aligned and directions correctly set and calibrated.

    Make sure also that motor inverted status is correct, perform Auto and correct pole numbers to actual by hand.

    Perform Follow offset auto.
  • Thanks for the pointers. However, I've checked and rechecked the IMU alignment and directions, and the motor settings many times over.

    Regarding the follow auto offset, I tried it and what happens is that now the gimbal begins to move uncontrollaby after startup. If I reset the offsets back to zero, the gimbal tilts right and forward after it has started.

    If I force the gimbal level by making it sit on a table while it starts up, then the camera remains level and there are no random movements. I am totally puzzled about all this - never experienced anything like this with my older 8bit controller.
  • If the gyro calibration is performed during startup, the gimbal needs to remain still during it. I always skip the gyro calibration on handhelds, and perform the calibration with button when needed. On Aerial gimbals it is ok to do the calibration at startup, just remember not to move the platform during gimbal startup.

    It is best to start the gimbal in non follow mode activated profile and after startup to activate follow mode if needed with button or RC.
  • I am having the same problem with the new firmware 2.44 b8. My roll and pitch will not level. When i switched back to 2.44 b4 then it is ok.
  • newgimbal, by "2.44 b4" do you mean the 2.44b4 (beta)? I've tried just about everything (including Garug's suggestions in the above) but the gimbal just refuses to level itself at startup. The firmware that I currently use is 2.43b9
  • It is really strange if it does not level. Is the IMU physically installed correctly. The gimbal will level IMU, not camera, so IMU should be precisely installed.

    Did you perform the Follow offset auto? and IMU is well calibrated? What do the indicators show, they should be levelled also at startup.

    If nothing seems to help, you should save profiles, erase EEPROM and re-perform basic setup.
  • yes. 2.44 b4 beta. I have tried 2.43b9 and it leveled. only problem i have is with the new firmware 2.44 b8 beta.
  • I erased EEPROM and it worked. Thanks Garug.
  • Garug, both the frame IMU and camera IMU are installed correctly and precisely (the camera IMU is mounted onto the camera tray). I have calibrated the IMUs many times over and checked and rechecked their alignment with a precision machinist square. The gimbal in question is DYS Eagle Eye and it is not the first gimbal I have assembled (though this is the first 32bit controller I've used).

    I have performed both the follow offset auto and tried setting the offsets manually. However, the offsets have no effect whatsoever - the controller appears to ignore them completely. I have enabled follow yaw, and also tried enabling and disabling follow roll and pitch but the controller still keeps ignoring the offsets. I've tried calibrating the gyro when the gimbal is sitting on a table and then checking the "skip gyro calibration at startup," but it doesn't have any impact on the camera's startup position.

    I have tried starting the gimbal with follow mode disabled and then switching to a profile with follow enabled, with no effect whatsoever. I have tried just about every imaginable setting and combination but the gimbal still doesn't level the camera & camera IMU at startup. The only way to level the camera at startup is to force it level by pressing the gimbal against a table while it calibrates the gyro, but relying on a table is not practical outdoors where there may be no tables available.

  • What are the indicators showing? Are you sure your RC initial angles are 0. You could also use these to adjust the angles, but not recommended. They should be 0 and gimbal levelled when starting in
    non follow mode.

    Do you have joystick connected, is it calibrated? Better use it in Speed mode.

    Did you try erasing EEPROM.
  • Hello,

    I have the same problem. Exactly the same things tried and the gimbal does not level the camera after startup. The same version of firmware. Did you manage to resolve the problem in the end?
  • I have a recently purchased 32-bit controller with the latest firmware. After going through the full calibration procedure, mine is doing the same thing. I can manually level it after power up but it does not level on its own. I downgraded to firmware 2.42b9 and it works fine. Whats the deal?
  • How do you manually level it???

    It could be some crap on EEPROM, especially if the same FW and GUI version was not used, but over all sounds pretty strange. What is the exact FW you had the problems with?
  • I level it manually just simply but pushing the roll and pitch axis to approximate level while powered on...

    I tried resetting to defaults and with no success. Also, calibrating the gyro and accelerometers multiple times, selecting to skip gyro cal on start up or not... no difference.

    This problem occurred on 2.50b3 and 2.43b9. I had to go down to 2.43b6 for it to work.
  • You have some weird settings. My advise would be to save your profiles and EEPROM so you can always go back, erase EEPROM and download newest FW and GUI and set all up manually according the users manual.

    http://www.levitezer.com/blog/files/961caec8b987076efd2f7ec37ca6bea0-27.html