EN RU CN
IMU Sensor not connected on older firmware Versions
  • Hello,
    I have a SimpleBGC 32-bit board. I am currently using firmware version 2.70b0 and the IMU sensors work perfectly. But I need to use firmware 2.60b0 (without encoders), and it seems that it fails to detect my IMU sensor. I have checked all the older firmware versions, but none of them cannot detect my IMU sensor.

    Could you please help me? @alexmos
  • Hello!

    This is because the IMU sensor that you bought, has a modern chip that was not supported at the moment when 2.60 firmware was released. You need old sensors having MPU-6050 inside. They are outdated and marked as end-of-life, but I think it's still not hard to find such breakout boards on the market.
  • UPD: Also 2.60 supports ICM-20608G which is better and I beleive is still produced.