EN RU CN
Booloader
  • I have just purchased an IFlight AlexMos 32 bit High Current BGC. This is the model I purchased: https://www.foxtechfpv.com/iflight-32bits-high-current-bgc-alexmos-authorised-p-1558.html

    Right out of the box, everything worked fine on the work bench with only IMU's connected and powered only by USB. The Device S/N was populated in the box and the Firmware Version wasreading as well. I thought, while I still had it on the bench and no motors connected, I would update to the latest software. I downloaded the latest GUI and firmware and did the "Automatic Firmware Updater" in the GUI.

    The firmware installed and finished. I rebooted the board and tried to connect to the GUI. The download of parameters takes about minute to complete. In the dialog box, an error kept flashing, "Serial Data Corrupt". then a popup would apear that sasys, "Something goes wrong when reading parameters:
    Error reading Profile 0: No Reponse
    Error reading Profile 1: No Reponse
    Error reading Profile 2: No Reponse
    Error reading Profile 3: No Reponse
    Error reading Profile 4: No Reponse
    Error reading adj. variables
    No response on CMD_READ_FILE Command

    None of the sensors will read and everything seams dead.

    The GUI will not display the Device S/N but it does show the Firmware Version

    I read the section in the manual about performing an emergency firmware recovery. I jumped the pins that I assume are the flash pins and tried the emergency firmware recovery. In the details dialog box, the response I get is as follows:

    Writing Firmware...
    Opening Serial Port COM11.. OK
    Writing firmware to STM32 bootloader ...
    Reading Firmware from file.. OK, 22244 bytes
    Connecting bootloader.. OK
    Disconnecting serial port COM11.. OK
    Error Upgrading Firmware: Timeout waiting answer from bootloader

    I have tried every version of the GUI including the 2.66b7 and 2.69b6
    I have tried every version of the CP210 driver that is available.
    I have tried other drivers that I thought might work.
    I have tried every possible combination of button presses and Flash jumping that is possible.

    My only other option would be to try and replace the bootloader on the board but I do not have the correct hardware to reflash the bootloader or the file to flash.

    What should I do at this point?

    Thanks, Michael