Dead serial comms pixhawk (ROLL pin mode)
  • Hi All. I like some help if possible.
    My gimbal and pixhawk have been working fine for a year, just using PWM for tilt angle.
    For better performance I decided to try the serial communication. Have now spent 3 solid days trying everything over and over. Have followed the manual exactly, tried re-wiring several times. trying to use TEMEL2 on pixhawk. Using RX wire on ROLL pin and TX on YAW pin (have also tried swapping).
    Getting NO an all AHRS,GPS,and the other thing. Also when try debug with heartbeat just get OUT message.
    have 2.60 and 3.0 pcb. Tried both serial channels.

    Guess I cant try the UART1 TX and RX solder tabs as this will disable the USB GUI connection correct? how would I then know if it connects?

    Have also check all advice regarding pixhawk side. Confirm protocol is MAVLINK not ALEXMOS? pixhawk wiki still says use ALEXMOS.

    If I join the TX and RX pins for test, should I see something happening on the debug screen?

    Anyway, Im completely stuck. Im an ex computer communication engineer and have no more ideas.


  • Well some progress.
    I understood form the manual that in the encoder (paid?) version of the firmware that the RX should be connected to AUX3, normal version it should be on the ROLL pin. As I dont have the encoder version I put it on the ROLL pin. Just tried it on the AUX3 and it has spring into life. 2 wasted days.
  • Now stuck again.
    Getting AHRS-ok, GPS-OK RC-no, Control-no.
    Again, been through everything. Hours and days have been wasted trying to get serial comms working.
    I wouldn't be the first one on here to say the support is appalling. This is the 3rd alexmos board Ive had but the first time I try to get some help, none is coming.
    Sadly I have just ordered one of the competitors boards because they have a very active support system.