Sbus on a cametv gimbal
  • Hi there experts

    I have a Cametv argo gimbal with 32bit board and have used the rc inputs to control pitch and yaw with an rc transmitter (9xr Pro) with a x6r receiver this works fine however I would love to be able to use the command function to toggle motor on/off to save battery as well. I think i read somewhere but cant confirm in this mode it only supports 2 channels. So I believe I can use sbus to get access to more channels but im not sure if the came-tv argo alexmos board has the sbus feature on it. I have tried to attach the sbus from receivers sbus port to each of the 3 rc inputs with mode futaba sbus on rc_roll then assign virtual channels but nothing seems to get to the gimbal

    Can you point me in the right direction please

  • See the users manual what pin to use for SBUS. Make sure the receiver gets power and is paired. Not all boards supply the +5V by default.
  • hi mate. The gimbal manual doesn't even mention the three rc ports let alone explain them. Receiver is powered no problem and paired (tried DJT and XJT) pwm direct works fine on the 2 axis only. Its more a question of if this 32 bit board includes the sbus feature on the rc_roll input.
  • See the picture, SBUS goes to RC_ROLL input if it is non encoder gimbal as I assume. If it is encoder gimbal, then Aux 3. If you can update the FW via GUI update and it is no specific Game TV FW, I see not why it would not work.

    You must select SBUS from GUI and corresponding virtual channels that you use.
  • Thanks for the extra info and taking the time to reply Garug. It appears its a modular board it doesn't have the aux port. it looks to be using the i2C method for encoders. 2x AS5600 and a AS5048A It only has the bluetooth (rf module) inputs and the three rc inputs. No other pins on the board. board picture here. https://www.dropbox.com/s/4zwzvm74ngh0mza/alexmos board.jpg?dl=0

    It is firmware upgradable and currently running 2.56 b9 (from the factory) maybe this board doesnt have the sbus option.
  • I am pretty sure the FW has the SBUS, but it might be that your board does not have the aux3 wired, the picture is not visible.
  • i have the exact same problem with a "dys saga", which i think is based on the same reference design. Only two PWM inputs, which work, but i need the SBUS flexibility. No idea where to go yet
  • hi everyone, someone here has maybe solved the connection with the sbus?
    It will help me a lot having my Argo with only Yaw working....Pitch via RC pwm seems not working at all even if the target is right on the GUI (as roll too)...Thanks!