Cannot get the YAW axis to follow the frame IMU
  • Hi all,

    I have an Alexmos32 with firmware 2.43b9, mounted on a DYS gimbal for Sony Nex camera. The gimbal is mounted below a 6-rotor massive home made drone. The gimbal / Alexmos is connected through a receiver to a DX9 radio.

    Here is my situation:

    1. The pitch axis works just fine: I have set the input mapping of the pitch to RC_PITCH and I am able to use to control the pitch axis perfectly.
    2. The roll axis is set to "NO INPUT" in the SimpleBGC software as I just need it to be stable around the "zero" position. When I turn the drone manually, the camera will stay horizontal on the roll axis perfectly.
    3. The problems come with the YAW axis. The YAW axis is stable, and I if I rotate the drone on the table, the YAW axis rotates automatically stabilizing the position to the position where it was initially turned on.

    The problem is that if I turn on the Alexmos with the YAW axis pointing to any initial direction (i.e. "north"), the gimbal will always try to keep that exact absolute angle. What I really want it to do is to follow the direction of the frame IMU, and I cannot figure out what I am doing wrong.

    With the input mapping of the YAW axis set to NO_INPUT, the YAW axis moves, but just keeps pointing at the same angle (say north). If I set the input mapping to RC_YAW, I am able to move the axis correctly, but once the movement stops it will not follow the frame IMU orientation and stay in whatever angle I have left it using the RC.

    The result is that if the drone is flying, the camera will always point in one fixed direction (i.e. north) even if the drone is pointing south, east, or west.

    I need help to understand what I am missing in the configuration..

    Thanks in advance
  • You are missing Yaw follow. see the follow tab.
  • Hello Garug and thanks for the hint.

    I have already tried to set the "Follow Yaw" in the "Follow" tab, but the gimbal still keeps a fixed position. Above you can see a screenshot of my settings.

    Is there something wrong with what I am doing?
  • Why do you have follow flight controller activated? do you have it (FC) connected and configured? if not disactivate that.
  • Hello again,

    I do have a flight controller, but it is neither connected nor configured. I have tried prior to posting the images having only the "Follow YAW" checkbox selected and apparently I had no luck. Sorry for posting a wrong screenshot.

    Just to be 100% sure, I have set the SimpleBCG software again to the following settings (see image), but the YAW axis still does not follow the frame IMU.


    I am quite sure that the frame gyro is working correctly because when the drone is on my table, and I rotate it around the YAW axis, the big "white arrow" in the YAW rotates correcly and indicates the direction of the front of the drone, that should be given by the frame imu. However, the camera that is mounted on the gimbal still keeps pointing to the same fixed point in space (say "north") rather than following - as I would expect - the white arrow.

    If I am not mistaken, in the SimpleBCG GUI the small red dot indicates the setpoint that has to be reached, and the little blue arrow indicates the current position of the axis. In a very simplistic way, the goal of the stabilizer system is to have the blue arrow follow the red dot and match its position. This is what is happening, but in our case, I would expect the "red dot" to be exactly on the tip of the "white arrow".

    This is not happening and I can't understand why. In the screenshot you can clearly see that the white arrow and the red dot positions do not match.

    Thanks again for any help! You are very kind taking the time to help me out
  • Yaw does not follow Frame IMU. no need to think about IMUs when setting the follow mode. Just set the gimbal working well and activate Follow mode as you like and it will works, if the gimbal works well without follow.

    Now your Yaw Follow speed is very slow. set it at least 20.

    Newer mind the indicators. the Pitch and Roll indications for frame and camera are useful, but rest, I have never understood.
  • Hello there, I am here to close the discussion with the solution.

    This was a rather strange coincidence that fooled me for a couple of days and that I could not understand; you will probably find this somewhat funny but I think it's better to let everyone know what happened in case the same thing happens to someone else.

    What we did was mount and connect the gimbal to our Alexmos, calibrate accelerators and gyros, set motor parameters and perform an auto calibration and then configure the remote control.

    What fooled us was the following: both the remote control was configured with inverted YAW axis setting, and the motor was connected inverted (and we did not select the appropriate checkbox). This is strange because PID settings tuning on the YAW axis worked flawlessly and it seemed to be able to find a very good and stable setting. After the calibration and setting, the end result was that if we moved the RC yaw joystick to the right, the gimbal would turn right and vice versa, exactly what you would expect; therefore we assumed everything was configured perfectly.

    However, the fact that the YAW axis motor was mistakenly configured as not being inverted, when it was actually inverted, fooled us. The compensation was working correctly, but it was probably compensating by decreasing the position delta rather than increasing it; the compensation was perfect but the end result was that the axis was apparently always pointing at the same direction because the compensation was moving the axis in the wrong direction due to the incorrect setting of the motor inversion setting.

    By inverting the yaw motor setting and the RC, everything started working perfectly.

    This was subtle but we figured it out. It took some time, I guess, because was working in apparente apparent way, but doing something unexpected: we assumed the fact to keep pointing always at the same direction was a "possible" configuration. The Alexmos was perfectly "counter balancing" the position error, with the result that the YAW axis was perfecly aligned to the same exact direction all the time. It was completely wrong, but worked perfectly.

    Just in case this happens to someone else, I will leave this for future reference
  • Good it worked out. This is exactly why it is important to perform the motor configuration Auto, its sets the motor inverted status reliably correct (but pole count usually needs to be manually corrected.)