Faulty motor pins?
  • On the 32bit board (2.42) i have problems with yaw and pitch motor pins.
    I guess it's the same prob i have on 8 bit: http://forum.basecamelectronics.com/index.php?p=/discussion/1140/roll-pin-is-dead#Item_1

    So my prob: the yaw and pitch motors are missing steps, like literraly (not only erro in gui) - i can see it on my gimbal. I even set max 255 power with high sensitive mode for picth but if you rotate the frame a little bit - the picth motors try to stay horizontal - but it can't reach the horizontal state: exactly like in that discussion: http://forum.basecamelectronics.com/index.php?p=/discussion/1120/strange-behavior-of-roll-axis#Item_1.

    What i've tried:
    1) i switched pitch motor to roll out - and it works like a charm.if i connect it back to pitch out - it behaves like above
    2) i checked all motors - all resistance are fine
    3) i checked motor drivers on the board - the pins that leads to motor pins are fine
    4) tried different pids
    5) calibrated gyro and 1 point accel
    6) tha bord looks fine

    For me it seems that yaw and pitch outs behave like the motors would if they are missing phase - not enough torque. All looks fine, but doesn't work. Any thoughts?

    P/S i can't reset controller. I tried to set reset controller in service for the button - but looks like nothing happens after it's pressed. I tried to press/hold button on the board - still nothing. Is there any software way to reset to defaults?

    Help appreciated!