EN RU CN
SimpleBGC32 Extended doesn't work with VN200
  • Hi!
    I try to use SimpleBGC32 Extended with IMU VN200 (as Main IMU on the camera platform) in my project: 3-axis gimbal, GBM 8028-90T motors, AS5048A (SPI) encoders.
    Firmware and GUI ver. 2.69b0.
    I started with standart IMU (MPU 6050). All settings was completed. PID and Encoders autocalibration was also completed. The gimbal starts to work as well! The PID autocalibration video (Movie 1) below.
    After this I change MPU 6050 (Main IMU) to VN200 via UART2 (Main IMU). All settings was completed according to the Datasheet. Encoders were disabled.
    Graphic instruments (GUI, Yaw/Pitch/Roll) began to correctly indicate the position and movements of the camera platform.
    Now I can see data from the VN200 in the External IMU tabsheet. See picture (Picture 1) below.

    Question 1. Why the SimpleBGC32 indicates internal IMU as Main IMU (Picture 1)?

    Now axis auto detection algorithm (Hardware tabsheet, Frame IMU sensor) doesn't work but MAIN IMU axis auto detection works and reacts to the movement of the FRAME (SimpleBGC32 is on the frame).
    The PID autocalibration also doesn't work and it looks very strange. See video (Movie 2) below.

    Question 2. In the VN200 data the "Quality" field = "Bad" or "Error" (Picture 1). Is it important?

    Question 3. How can I set the internal IMU as Frame? I think that is the problem!

    Thank you.

    Movie 1:
    https://drive.google.com/file/d/1-UjLq3h_DZkuADNRkt2D3S30bUq8wpq2/view?usp=sharing
    Movie 2:
    https://drive.google.com/file/d/1-TY2HsCjVLyL4xzseODc5AOC9gJgNVF_/view?usp=sharing
    Picture 1.
    https://drive.google.com/file/d/1-TJs4GP4ZQzZx5-3zIi3-OP4k8WZoi0B/view?usp=sharing
  • Hello,

    1,3) I see only one thing that may be the cause of all problems: you considered external IMU VN200 as a replacement for the main IMU, but it is not true. External IMU works only as companion, it does not replace the main IMU! We still need its gyroscope as a source for feedback signal for stabilization. So you still need to connect regular IMU and place it on the camera platform (aligned to VN200). Even if gyroscope in internal IMU is not precise, it provides data with minimal delay at high rates. A gyroscope in VN200 may be used as a reference (if set "Gyro online calibration" option).

    2) it may be a wrong interpretation of the status flag of VN200, so it is better to check its status by connecting from the tool provided by the manufacturer. If all is okay, ignore this value.

    Regards, Aleksey.
  • Hi, Aleksey!
    Thank's a lot! Now it works! :-)
    But I have a new question about the tuning algorithm.
    I have to complete all the settings and calibrations of the gimbal with regular IMU and then just add VN200.

    How should I use the IMU 21-point calibration data?
    Now I have two files: for MPU6050 (use it while tuning) and VN200.

    And what about other IMU calibrations?

    It would be great if you described the VN200 connection more detailed in the Manual. But I think it's not so popular configuration.

    P.S. If I try to start PID-calibration with MPU6050+VN200 the gimbal still calibrates very strange. But it works with previous PID data.

    Thank you!