Problems with YAW drift and HOT motor
  • Bear with me as I just joined the forum, and know you are all expert level in comparison to me. That being said, I worked out a lot of my issues by using the resources on this forum, and am grateful for its patrons. Now the details of my problem.

    I have a came-tv 7800 3 axis gimbal. It features an alexmos 3.0 board, 32 bit, and features a frame IMU and a camera IMU. I got it used about a year ago and have hardly used it because of issues. Today I ended up moving everything back to the factory position and starting from scratch to try and balance my camera (3lbs). I think the balance is pretty close to perfect It will hold pitch at any 45* angle, forward, back, top, down, etc, roll holds level as well as 45* left or right, yaw is the tricky one for me, but it does not swing front or back when picking up either the left or right side of the top tube. I was having an issue with my roll tilting randomly and with any type of other movement, but I did a rough IMU cal on the camera IMU and did a gyro cal and that seems to be resolved (fingers crossed). What was a problem before and still is is that the yaw continuously turns counter clockwise about 1* every 10 seconds. Maybe not quite that fast but give or take. It seems to do this regardless of what mode the camera is in, with follow mode enabled or disabled. The only time it stops is when I select angle mode rather than speed mode in BCG.

    In addition to that, the yaw motor is very hot. I am not using the gimbal, it is literally on a set of light stands while I work out these bugs, so I can't see why the yaw would be working so hard in the first place. I've read for hot motors I might be giving it too much power (default settings), but what about the drift?

    Lastly, is the gyro for the camera IMU and frame IMU the same, or do I calibrate the gyros separately like I do the IMUs?

    Thanks very much in advance.
  • Additionally, I am not seeing how to calibrate the joystick. I looked under RC but don't see anything that says reset or calibrate. Am I just missing it?
  • same of you!How did you solve this question? please!
  • I'm sorry but I haven't solved it.