EN RU CN
Non-liearities correction calibration does not work
  • I have 3 14-pole motors on my gimbal, Firmware ver.: 2.63 b0, board ver.:3,6.

    For some reason when I try to calibrate motor non-linearities correction I get a message "Error: failed to process calibration".
    Yes, I have deleted previous calibration data and selected all axises for calibration.

    What can be the problem here and how to fix it?
  • Hello!
    Actually I can not say why it is not working, because there are no detailed error status send by the firmware. Check the following conditions:
    1. Motors are turned ON and stabilization is working.
    2. you selected at least one axis to calibrate.
    3. you understand what all other parameters mean and they are set correctly.

  • I have the same problem...

    Using SimpleBGC32 GUI v.2.63 b0 on a Windows machine
    Using a board labeled SBGC v.3.7 "Extended" (GUI reports it as 3.6)
    Firmware: 2.63 b0 (with encoders)

    The motors are ON, I deleted the previous data, and selected just the PITCH motor to calibrate
    I'm using the default calibration parameters: 180 deg., 30% smoothing, speed = 30, period = 10 (auto-detect selected), 2 iterations

    MAVLink is disabled, RC_ROLL pin mode = Normal, there are no I2C errors

    I've tried starting the calibration with my encoder enabled and disabled. I've tried starting the calibration when I'm connected to the board by WiFi and by USB. Nothing makes a difference -- I always get the "Failed to process calibration" message.

    Has anyone ever gotten this function to work? What else can I try?
  • Hello!
    Does gimbal works in the "encodedr" mode? It means that encoders are enabled, functional and calibrated for offset and el.field offset. The "motor power" indicator is near zero.