EN RU CN
Help with flashing new firmware!
  • I have recently bought a gimball, and now I want to flash the latest firmware onto it ... At first, I was not allowed to connect to the electronics error: avrdude: stk500_getsync (): not in sync: resp = 0x00 ...
    when I tried to flash the new firmware, I get the error: firmware 0.53 4b not in sync with the latest GUI version 2.40 b6 ... where can i find the GUI version for 0.53 4b and then how can I upgrade it please help...!!
  • Okay now I got connected to the board with GUI version 2.2, but can't get the latest firmware on it...??!!
  • Failed to upload: Error writing firmware: invalid avrdude exit code (-1073741515)!
    ??
  • Are you using Mac or PC, FW update works only on PC. From download page: "Starting from version 2.1, firmware upgrade is possible from GUI. Another options: you can upgrade firmware using XLoader or AvrdudeR utility. ... " As you have old FW maybe you need to use XLoader
  • Thanks for reply Garug... - Im using a MAC with Bootcamp XP, and a PC with XP, nothing work ill get different errors... Its possible to connect to the board, flash and read, but not upgrade...?!? tried with Xloader and Avrdude - no luck...?! The board is purchased via Hobbyking...
  • I just tried to downgrade firmware to 2.1 and 2.0. This is not possible, get the same error: Error writing firmware: invalid avrdude exit code (-1073741515)!...?!?
    What to do now?!?
  • You have to install the new firmware on a PC. After that you can already use the mac version to tune it
  • I did try to install the latest firmware from a PC, even tried to downgrade it... But nothing worked... Still the same error...
  • First you have to install the VCP Drivers on the PC to recognize the COM Port:

    http://www.silabs.com/products/mcu/pages/usbtouartbridgevcpdrivers.aspx

    Then open SimpleBGC, connect to COM port and upgrade firmware from GUI…

    I did it just now on a PC (less than 5 minutes)… the only thing is when I connect it again to the mac, no "COM(number) Port" appear in the connection tab, but a "/dev/cu.SLAB_USBtoUART". When I connect to this port it looks that everything is responding good…
  • I did this, and its still not possible to flash old or new firmware...
    - I CAN make changes in the original firmware - new profiles, changes PID's ex.
    But its the Up and Downgrading that dosn't work...
    Thanks anyway;)
    BTW, tried to do this on 3 PC's and one MAC now.... Still no luck...
  • you have to install the .hex file. Upgrade from whithin the GUI. It will give you version mismatch...follow the steps and it´s done.
  • Thats what im trying to do, when it happens it gives me an error: Error writing firmware: invalid avrdude exit code (-1073741515) - No steps to follow, so its hard to know what to do...?!
  • Update on MAC does not work, gave me something similar. Under Windows 7 it was ok. use the .exe file on Windows and keep everything on the file structure as provided.

    My at December from Flyduino bought board was FW 0.53 but updated nicely to 2.4 on windows.

    One thing maybe to ensure, what baud rate do you have on the board?
  • Tried with my PC with XP - no luck... Just checked my structure - Its like provided... As I remember it I tried Baud rate: 115200, 57600... Still no luck, I wil try again when i get home from work...

    BTW, Thanks for bother to help me...
  • No problem, hopefully you get it shouted out.

    Still one thing to verify, maybe good to have external power and motors unconnected.

    And USB cable. I have had problems with USB cables. Short and good quality cable for FW update.
  • I have some issues\, same problem as above not sure what board i have but it came with a gimbal from china, the board was labeled basecam electronics I'v tryed every way to make this board work and hostilely i got somewhere :) everything worked on 2.2b witch is what it came with from what the GUI says, but as soon as i downgraded to 2.1 every thing stopped completely and even trying to load 2.2b back didn't work witch leads me to believe that there are hacked versions of base cam controllers that use a third party type of firmware that only can be configured with the basecam GUI but if you change to basecam firmware your no longer able to, can't say for sure, OKAY the good news I was able to use Arduino to burn boot loader back cuz version 2.1 bricked the device and flashed BruGi_050_r217 to it and was able to surprise myself that it worked and only got a small 1 small error when connecting, so everything works but the RC inputs, it did for a few minutes then i noticed the role and pitch were moving with one another slight role when given pitch input the Arduino code can be changed up and fix the issues witch is cool but i don't know how to do such think ATM
  • HI I bought the same board labeled as 'basecam electronics' when I tried to update it says that it has version for 0.53 4b, is this a fake board? the I think I lost the firmware since the board could not connect serial with thierror: avrdude: stk500_getsync (): not in sync: resp = 0x00
  • Hello! pedro, please, send photos of both sides of your board.
  • Anyone, please help!
  • I only see 2 motor outputs so i presume this is a 8bit 2 axis controller. From what you mention that it is version 0.53b4. Most of my encounters/experiences with fakes narrow this down to a replica board. It cannot be updated. you can only used GUI 2.2 as mentioned in the above post.

    Next time buy from the shops approved in the buying section here and you won't go wrong.
  • I have having the same issue with mine. I've connected to PCs and two macs. On the Mac I can see the com and it shows "connecting" but never connected. I CAN NOT flash the board to get it too a common state or start over as it was. There has to be a way to get this back to a reset?
  • Hello, DangerD, pedro - where did you get that board?

    delano, Did you download this driver?
    http://www.silabs.com/products/mcu/pages/usbtouartbridgevcpdrivers.aspx
  • I have the exact same board and the same problem .. has anyone been able to resolve it ? I also got a usbasp card but would need to know where the MOSI , SCK and RST pins are ?
  • Kay been playing around and I connected a paper clip between rx1 and tx1 and now it seems I can connect to it again with the software .. need to try a few versions .. I get "GUI vs Board version mismatch"
  • @AndrewSupport

    Same problem, same board. Can confirm that the board is an illegitimate clone based off of the 8-bit Atmega128p models. I've attached a link to the Amazon page of the gimbal it is being sold with. In my experience, the retailer was Andoer.

    The boards appear to function normally save for the fact that they have their A0-A3 pins in a different order and have a micro-USB type B connector attached to the board. Let me know if you'd like me to send you any pictures of the board I have.

    http://www.amazon.com/gp/product/B00GAY5YBU/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1
  • keyton, Hello, Please, send us photos of both sides of your board in high resolution.
    If your board is clone or counterfeit we don't recomend update board, because you can damaged this board by our software.
  • I have the exact same problem - here are pics of the two sides of my board -
    https://onedrive.live.com/redir?resid=DAA1073726EBD73B!119345
    https://onedrive.live.com/redir?resid=DAA1073726EBD73B!119346
    Bought on eBay in December from a supplier with 55,000 positive feedbacks, so presumed OK!
    GUI v2.2b2 loads OK and lets me work on the board, but I cannot upgrade the firmware to SimpleBGC_2_40b8.enc.hex using either GUI v2.2b2, or GUI v2.4
    Can I assume I've been "done" and bought a cheap clone? I'm using it with a DJI Naza (on a Flamewheel), and I've taken the precaution of running both the Gimbal controller and the FPX transmitter from the main lipo through a 1A Anti-surge fuse (though something slightly smaller might be better).
    Is there any risk to my Naza if I connect it to this clone board, or is it just a case of it being a lower quality copy of the original Basecam board?
  • Stagesound,
    You bought Chinese imitation.