EN RU CN
USB and Lipo connected simultaneously, is it OK?
  • I purchased an Alexmos board and a 3rd axis addon. I used USB port to make the necessary initial adjustments. The I connected the motors and start to test the gimbal. It is working like a charm. I cand talk with the board and I can configure normally but something tells me that is not right to use 2 power sources in the same time - Lipo and 5V USB.
    I tried to use a FTDI and a Prolific adapter for configuration (and to avoid powering the board from 2 sources, ) but I couldn't connect to the board.
    My question: is it OK to power the gimbal from the Lipo battery and in the same time having the USB connector plugged in?
  • Hello!

    Yes, it is not harmfull at all. I am always tuning gimbal with USB and LiPo connected.
  • OK, that's great, I'll be less nervous with the future configuration operations :). In the meantime I managed to connect to the board through a Bluetooth module.

    Thanks Alex!
  • To anyone thinking of trying this, DON'T DO IT!
    I found this thread while checking to see if this would be safe, and was lulled into a false sense of security by this reassurance.

    I plugged my board into a 3S Lipo, then plugged the USB into my laptop with the front end software ready.

    My PC immediately turned off, and the chip on the gimbal controller next to the lipo connection released its magic smoke.

    I was sad to lose my gimbal controller before I even got to use it. I was even more sad it took my new laptop with it. It's toast.
  • What board is it? With the 32 bit boards I am always having USB and power connected when tuning, no problems. Also with 8 bit boards I did this and it was ok, Some 8 bit boards tried to provide power to motors and I did not like that, but never really any problems.



  • it was an 8-bit board. To add insult to injury, the board still works powered by USB, but not from lipo, so it can't power any motors. My laptop is gone though, just completely dead.

    I suspect it was a Chinese fake board, but it has Basecam Electronics written all over it.

    I would post a picture, but can't see how. It was the one with two 3 pin connectors for Pitch and Roll, and a space for a third connector for yaw, all along the one edge.
  • Hello,
    Upload photo to dropbox.com and place link a link here.
  • Here you go:

    https://onedrive.live.com/redir?resid=e1a08e4623c452a4!724&authkey=!AExVHdoneWIgMhI&ithint=folder,jpg

    There's a picture of the front of the board, the back of the board, and a close-up of the component that burned.
  • The burned component looks like AMS1117 5V regulator. that also explains why USB power is needed to power the board.

    What would cause that and why would it then leak the main power to USB ?

    It would not be good idea to connect 5 V to USB, but I do not think that would harm it. The USB ports normally have fuse. Butting 12 V to USB post could be harmful as the fuse would not have time to work, but that should never happen.
  • Thanks, Garug, for the identification. I guessed it was a regulator, but was unable to identify it from the partial code remaining.

    Yes, it explains why it no longer works from battery power. What surprised me wasn't that, but that burning out the regulator managed to toast my PC through the USB, but left the rest of the gimbal controller board working. I had thought that the microcontroller would also be toast.

    I am not entirely sure what happened myself. I will detail exactly what I did.

    On receiving the board, I connected it to a PC, and verified that the sensor worked in the front end application. Everything fine.

    I then assembled the gimbal with motors, mounted the camera so the weight would be correct, and having read that it was not safe to connect motors while only on USB power, then powered it with a battery. I expected it to be strange as it was not yet configured.

    It powered up, the motors briefly moved feebly, then it stopped and flashed the green light quickly. I unplugged it from the battery and plugged again. This time no motion, just green flashing.

    It was at that point that I decided to plug it into the PC to see if the front end would tell me what was wrong, and to tweak the settings. I checked here whether it should be safe, and reassured by the message from Mr. Alexmos himself, gave it a try.

    Of course, I never got any further.

    It makes me wonder if something had already failed on the board, which is what caused the feeble motor motion then nothing.

    I may replace the regulator and see if it works after that, but I certainly won't be connecting the board to a PC again when on battery power.

    Looking at the pictures of the board, were you able to tell if it is a fake?

    Thanks again for your help.
  • Your board haven't any components to switch between the 5V regulator or the 5V USB power.
    The USB power is directly connected to the 5V output from the regulator and this gets wrong.
    Or it's a fake board or they have made a big mistake.

    If you can fix the 5V regulator...
    The only safe way to connect your board (including a LiPo) to the PC, is to use a BlueTooth connection.
  • I have this same board and can connect Battery and USB at the same time. no problem.
    I am having trouble trying to communicate and flash it.
    Is it a 32 bit board? are there flash pins? is it a real Basecam?
    Thanks.
  • > Is it a 32 bit board? are there flash pins? is it a real Basecam?

    It's a Chinese immitation.
  • Ah OK thanks. it's also 8 bit chip I see.
  • Seems like you got your answears allready
    But i just want to chip in with my experience.

    Both my cards 8 and 32bit works fine with power and usb connected.
    After all how are you supposed to tune the gimbal if they cant?
    5v from the usb isnt enough juice to tune the motors with payload.
  • My board is 8-bit and I ALWAYS connect first the battery and then the USB.

    Why? Because I read all over the Internet using just the USB power might burn the controller, and because without battery, my motors can't supply enough power to hold the camera into position... by far. I tested it... accidentally. Luckily, it didn't burn.
  • Thanks to everyone for all their responses. My first post was mostly just to save anyone in my position from doing the same, and finding this post and assuming it would be safe. Now they will see this discussion and be better informed.

    I read the same information as Octovisuals, so connected the battery first. It didn't save me.

    @Mrimstad: You can tune it via a bluetooth module, or just change a parameter while on USB (without motors), then disconnect USB, connect motors and battery, see how it is, disconnect battery and motors, connect USB and try again. Irritating and slow, but at least it won't fry anything.

    @kirkc: It does have an ISP connection for programming. From what I now understand it cannot be programmed with the official firmwares, or updated using the front end software.

    I have ordered some replacement regulators, as they cost less than $1 for 10, and will see if my board can be resurrected.

    A replacement USB daughterboard and motherboard for my laptop however cost an awful lot more.
  • Too bad...

    Anyway, tell us how the repairs go!

    Best regards.
  • Id say that would have been a design flaw with the card if you had to tune it that way.
    The bt is also a addon piece and should not be needed for tuning.

    Anyway seems like you have your cause and your cure.
    Good luck. Shouldnt have happened in the first place, but atleast your man enough to fix it :)
  • Hello Garug,

    I am new on this forum, and this is my first post. I experienced a weird problem yesterday. I was running my gopro using the Alexmos gimbal. Everything was working perfectly fine. But then when I tried to run it again after few hours, I realized that when I attach 1000mAh, 3S lipo, the green light on controller board will turn on and off every second, and motor makes clicking sound and gimbal no longer works. But as soon as I attach it to my laptop's usb port, everything starts working fine! So now I have to apply power from lipo as well as from usb port to make gimbal work :-(. Lipo voltage is okay. Nothing looks smoked/burnt on the controller board. It still looks like 100% OK! Can you guide me how to troubleshoot this problem?

    Thank you..!
  • Sorry but I really do not have solution for that. It sounds like the board is broken.

    What board is that?

    You could verify that no alarms is causing it like voltage compensation, but with that it should not make any difference if it is USB connected or not.

    Also you could verify that you have + 5V present on board when connected battery only,. To do that that you need multimeter and some basic electric skills.
  • I have seen the board only function when the USB cable was attached (and not with the battery only). Replacing the 5V regulator on the board fixed it.