EN RU CN
Help fixing mistake made while flashing
  • Hi all

    I am new to all of this and I have made a mistake while trying to get my gimbal up and working.

    I have a GLB V3.1 2 Axis gimbal and when i tried to connect it to the 2.43b9 GUI that I downloaded it said that it couldn't connect because there was a type mismatch between the firmware and the GUI. So I then tried to upgrade the firmware so that it was the same type. Finding that I couldn't use the auto option, I did it using the manual option and used the Simplebgc_32bit_recovery.hex file that was in the firmware folder as part of the GUI download. Since doing that I cannot connect the gimbal to the GUI via the COM port. I can see it as available, but when I try to connect it just gets stuck trying to connect. Obviously whatever firmware I tried to use was wrong, and I was hoping there was a way to just restore it all to factory settings, but I can't find a way to do that.

    Any help would be greatly appreciated
  • 2 axis gimbal sounds like 8 bit. Make sure first is your board 8 or 32 bit and use correct GUI/FW
  • If this is the same board: http://www.goodluckbuy.com/glb-3-1-2-axis-brushless-gimbal-mos-controller-with-gy6050-sensor.html

    It's for sure a 8-Bit version !
    This board is using a other Atmel processor, so with some luck you can upload the latest 8-Bit firmware:
    http://www.basecamelectronics.com/files/v10/SimpleBGC_2_40b7.enc.hex
    http://www.basecamelectronics.com/files/SimpleBGC_GUI_2_40b7.zip
    Please read the manual step by step, how to upload the firmware.
    http://www.basecamelectronics.com/downloads/8bit/
  • MdG_NL, there is no genuine controller on your link. So original software can damage this board.
  • Thanks Yu3u, I didn't noticed this.
    And if this board isn't a genuine controller, my support will stop here.

    @ MaxFinch,
    Please order a original 2-axis controller, if you like to get support.