EN RU CN
USB driver problems
  • Hi all! I am a newbie to the gimbal world. I have purchased a gimbal assembly from a friend of mine. He told me 8bit system and to use the instructions and GUI for the 2.2 firmware. Following the instructions, I downloaded and installed the virtual USB driver onto a Windows XP machine. Hooked up the gimbal and started setting it up. I was trying to get the roll motor tuned, made an adjustment and hit write. The write to unit failed, communications to the unit also failed. Now I can't get it to work on any of my PCs. I've tried 4 different PCs and all of them have the same result. The GUI starts right up no problem. When I plug the unit into the USB, I get the "device not recognized" from windows. Tried uninstalling and reinstalling driver with no luck. I tried turning off my antivirus with no luck. Anybody know what could be causing my problems?
  • Bad or low quality USB cable.
  • As well, may be nulled firmware?
  • Forgive my ignorance but what do you mean by "nulled firmware"?

    When it was connected to the GUI, it did say that the firmware was 2.2
  • Nulled firmware is a hacked one. When you upload the official firmware on such boards they "die".
  • So basically my board is now a digital glass coaster.
  • yes, if it was hacked one.