EN RU CN
Roll affects yaw and vice versa
  • I noticed that if I move the roll axis, the yaw axis moves slightly, either in normal or follow mode. If I move the yaw axis, the roll tries to move (but gets stabilized, obviously). That only happens when done by hand, not by RC (luckily...).

    Why is that?

    I'm using 2.4 b7 8-bit and I did the 6-point accelerometer calibration already.
  • Is this interference normal or am I missing something? What can you tell me about your gimbals, guys?

    Maybe if yaw moves during agressive flying or in windy conditions the roll would be affected, so I must know more about this issue.

    Thanks.
  • Interconnection between axis can be:

    - Simply because the gimbal is not in level, it stabilises the camera, not each axis separately (tilt the handle (yaw motor 30 degrees back and move the yaw with joystick to demonstrate this clearly)
    - The gimbal is not accurately build, all axis are not exactly 90 degrees to each other.
    - the IMU is not perfectly calibrated or perfectly aligned when installed.
    - Follow offset is not correctly calibrated.

    Small imperfections are normal. if it does not show on video, no need to worry about it.
  • OK, Garug, thank you very much, appreciated. I'm more confident now about the small imperfections.

    I'm still testing thoroughly to see if it can affect the video in some way. Fortunately, I don't think it does for what I've seen so far, though.

    Best regards.
  • Confirmed, it does not affect video, luckily.

    In fact, it only happens when the gimbal is standing with the legs, and the yaw/roll motor lose steps and transmit the movement through the carbon fiber. This does not occur when the gimbal is lifted by the yaw axis, not touching the ground, as when handheld or flying.