EN RU CN
Set up GUI for Apple iMac - problem with COM serial port
  • Hi there,
    I am having trouble in setting up the GUI on my iMac (OS X 10.9.01 mavericks). Actually the problem is on the COM port! I cannot get the USB to SERIAL jack to work and to be seen.
    And when I launch the GUI, I cannot see the port in the list and get the GUI connected with the board.
    I tried to get it to work on Windows xp (on bootcamp partition) but there I have another kind of problem (that is I cannot upgrade the firmware using AVRDuder), it says some files are missing...)
    Is anyone able to help me setting up this COM port?
    Thanks in advance!
  • If you are updating FW you need to get it operating under Windows. On OSX the FW update does not work. Parameter settings is ok under OSX.



  • Ah btw more info:
    I installed the FTDI USB serial driver from FTDI chip website
    I installed (hope correctly, not that easy instructions) the D2XX files into library
    I think that the con port is not working...
  • Thanks Garug. Under Windows xp when I try to update the FW i receive this error (using AVRDuder):
    Impossible to run the application, file libusb0.dll not found. A new installation may solve the problem (translated from Italian to english)....
  • Found the libusb0.dll file and copied to AVRDuder dir and now flashing the FW get this msg:

    AVRDuder.exe: stk500_getsync(): not in syinc: resp=0x00

  • Are you using AVRDuder somehow separately ? just try with the GUI FW update under Windows. Keep all the files in the directory as they where when downloaded.
  • Dear Garug,
    Thanks for your help.
    If I try to use the GUI tu upgrade the firmware, it says GUI version 2.40 incompatible with Firmware version 0.02 b
    If i try to use AVRDUDER separately, i got that other error (stk_500 not in sync...).
    Help!
    I am wondering to use a Windows PC (not an iMac) and try. This weekend hope to find friends with PC...
  • Donnelly you can upgrade from whitin the GUI. Just need to know where you have the hex file for the same FW version
  • HI Kikojiu
    I have 2.40 GUI and 2.40 hex file, downloaded from this website. But the GUI doesn't let me upgrade since - it says - its release (GUI) is incompatible with release of the board firmware, which is 0.02 b.
    Maybe you mean I have to find GUI version 0.02b?
  • GUI is supposed to do the FW update since 2.2, so 0.02 GUI would not work. I have had problems also connecting different FW boards and GUI's. However one of recently bought board (Flyduino) had FW 0.54 but updated nicely on 2.4 GUI. I really hope this would not be so complicated, I guess it has something do to with protecting the code...

    Maybe some GUI between 2.2 and 2,4 would work for you, otherwise I am afraid you need to use something more complicated like AVRDUDER.

    Can you cases the board with any GUI. One thing to verify is that the board and FW flasher baud rate are the same.
  • Ok, I will try both these options:
    a) do the work using a Windows-Intel PC (and not my iMac) [this weekend I should get one borrowed]
    b) download the older GUI possible (on this website I saw it is 2.01 or similar)
    and then let you know.

    @Garug: I tried using AvrDude but don't know why it crashes with error
    stk500_getsync(): not in sync: resp=0x00
  • Tried with GUI version 2.01 and it sees the board and read data. Not Sure if it also writes data, since I tried a different set up of P, I and D values and only result is that gimball now goes crazy and bounce continuosly after reset. Also pitch indicator now is inverted (moving te camera up and indicator pitches down). Tried to flag inverted on motor for pitch but nothing changes. Also upgrading the board was impossible due to an error using firmware update in the GUI (vers 2.01 as GUI) that at the end says: AVRDuder error...
    I am really really frustraded about this product...
  • Donnelly - have you solved this problem>?