• I'm using a MAcbook Pro and a Imac. I installed on both computers the Gui with the FTDIUSBSerialDriver and Mac_OSX_VCP_Driver. But the Gui doesn't run. It starts shortly and at the top left there is for 2 seconds the Gui name. After that the Gui is closed.

    Any idea for me? Working since three hours with this problem.... :-(

    Regards oerybln
  • try restarting the mac.
  • i didi it a few times!! nothing!!
  • Are you connecting trough FTDI?

    Do you have latest version of the Java etc environment?

    Also did you follow the instructions,, there is a readme.

    Runs ok for me.
  • Yes... I installed this components:

    Mavericks, Java Version 7 Update 51, http://www.ftdichip.com/Drivers/VCP.htm, http://www.silabs.com/products/mcu/pages/usbtouartbridgevcpdrivers.aspx

    But no excitability ... :-(
  • Didi you do this?
    MAC OS users: GUI uses a serial communication, that needs to create a lock file.
    To allow it, you should to do the following steps:
    1. Start terminal (navigate to /Applications/Utilities and double click on Terminal)
    2. Make folder "/var/lock" by command: sudo mkdir /var/lock
    3. Change permissions by command: sudo chmod 777 /var/lock
    4. Allow to run non-signed applications in System Preferences > Security & Privacy >
    General > Allow Applications downloaded from: Anywhere (see http://d.pr/i/9fAm )

    Are you sure it is FTDI and not CP2102 you should be using.
  • Many thanks for your help Garug!!!!

    I installed both. that could be the mistake...?!
  • The problem is how to uninstall the CP2102!?
  • I do not think this is the problem, I have both installed and some more as I have also Arduino installed. In fact I think it should run also without either as it runs also over Bluethooth etc.

    But have you the lock file created?
  • yes... i hope so!

    thats the terminal:

    Last login: Fri Feb 7 08:47:11 on console
    kerstins-mbp:~ kerstinhense$ sudo mkdir /var/lock
    Password:
    mkdir: /var/lock: File exists
    kerstins-mbp:~ kerstinhense$
  • sorry...

    thats the terminal:

    Last login: Fri Feb 7 08:47:11 on console
    kerstins-mbp:~ kerstinhense$ sudo mkdir /var/lock
    Password:
    mkdir: /var/lock: File exists
    kerstins-mbp:~ kerstinhense$ sudo chmod 777 /var/lock
    kerstins-mbp:~ kerstinhense$





  • I have Mac Book Pro 2010 with fresh installation of newest OSX operating system, runs fine. I am really out of ideas what might be causing your problems. Only thin I can think of is that I have Arduino environment installed, maybe it instals some necessary components.... but I do not think so.

    Just to make sure, you are starting the SimpleBGC_GUI.jar, i.e. not running the SimpleBGC_GUI.exe on Parallels etc.
  • Im having the same problem.
  • Can some one help to fix this problem, when i open Gui he shuts down after 2 seconds.
  • I installed Arduino like Garug said but no change again... going crazy!!
  • One thing to check, have you allowed OSX Security&Privacy / Allow apps downloaded from: Anywhere ?

    It could be OSX stoping the start of the program.

    Also how have you "installed" it? I have just copied the whole folder SimpleBGC_GUI_2_40 to desktop and I go into it and click open SimpleBGC_GUI.jar. There could be some folders that need to be under the folder where SimpleBGC_GUI.jar is started.
  • Anywhere ist marked at OSX Security&Privacy. I installed the zip file and clicked the gui 2_40.
  • It is a mystery then, my last guess would be something on the Java environment. Maybe reinstalling it and making sure it corresponds to the OSX version. Did you perform the Java environment test after installation?
  • Yes I did... But the mystery on two computer?!?!? It's the revange of steve.... :-)

    Ok it is not a drama because the GUI works with an other Macbook Pro but it has a small panal damage and will be changed by a new MacBook Pro. But I think the drama will come back... "urgs"
  • I have installed java again with no results...
  • Me two... And controlled on Javasite. It's running but Gui not working...
  • I open GUI with no problems in a 2011 MBP running Mavericks…

    My problem is that no "COM(number) Port" appear in the connection tab, but a "/dev/cu.SLAB_USBtoUART". When I connect this port it looks that everything is responding good when I move the sensor…

    Then I tried to upgrade firmware but it failed on OsX. So I upgraded it in a PC (less than 5 minutes) and tried again on Mac. Still the "/dev/..." port and no easy-named "COM Port", but looks that everything is working and got the latest version:

    http://studiokrrusel.com/wp-content/uploads/2014/02/Captura-de-pantalla-2014-02-22-a-las-11.59.20.png

    I don't know if this "no-COM-port" could be an issue during calibration process, but for the moment I am quite happy to see communication between my MBP and the board...
  • benico found a solution:

    bencio February 2015
    Just found a solution: http://blog.iharder.net/wp-content/uploads/2009/08/librxtxSerial.jnilib
    Download this file and put it in this directory library/java/extensions deleting the existing one if i understood well is a problem of libraries compatibility between 32 and 64 bit architectures