EN RU CN
Parallax 27800-RT thumb stick Smokes after about 2 minutes of offset control
  • Hey so I purchased and hooked up the Parallax 27800-RT for offset control and it works pretty damn well actually! Until it smokes :P. So I am using the 5208 iPower motors with 200 turns. I have an 11.1 volt battery and I have my rig pretty well balanced. The controller seems to get a bit warm but I assume this is normal considering the motor controllers. I followed the wiring diagram to hook up the joystick and set the control in the software to analog and it worked well. I was getting very fast and flexible control via the two axis I wanted, Pitch, Yaw but the fun didn't last and the joystick got too hot and became damaged. I assume I either did something wrong(hoping!!!) or that I need to pass my joystick through a micro controller to output PWM instead of analog :(. Any advice would be MORE than appreciated!!! Thanks!
  • How did you connect it? 27800-RT seems to be 10V maximum, so if you connected it to 5V correctly, there should not be any problems.
  • So based on this diagram http://www.basecamelectronics.com/files/v10/SimpleBGC_connection_diagram.pdf I am connecting to the 5v and ground of the RC_Pitch input. I am then connecting the U/D and the L/R to the PWM(analog in my case) pins for RC_Pitch and RC_Roll(I have RC_Roll piped to the YAW motor in software). On the actual joystick I have a lead going from the 5v to each + input but I only have 1 lead going to Ground. It worked really well for about 2 minutes until it got to hot and burned up the potentiometers within the joystick. Now I do have an older board. It is one with an extension for the 3rd axis, not sure if this matters.
  • It sounds like you have connected it like this http://www.datasheetlib.com/datasheet/1148642/27800-rt_parallax.html?page=3#datasheet . So that should be ok, so something strange if the joystick is burning? could be good to verify the 5V input to the joystick with multimeter, but even that should be ok, because it was operating ok. Maybe faulty joystick?

    Or for some reason voltage was leaking to U/D or L/R. that would burn the joystick easily when moved towards GND. temporally short-circuit between L/R and LR+ or L/R and U/D+ would do that when the joystick is moved to its extremes.

  • Yes that is correct, I used that diagram actually to hook it up. I did find something odd early on in my research which later disregarded until now: http://aerialpixels.com/support/alexmos-joystick-connections/ these guys show the +5v being ignored in the RC pinout and they're pulling Vcc from another source on the board. Is there something to this possibly? Thanks again for the assistance!!!
  • As your battery is 11.1V so even if that would get to the joystick voltage inputs, it would not burn it in couple of minutes and likely not at all. And as it was working ok, I think the input voltage was ok.

    I would suspect that for some reason input voltage leaked to L/R or U/D.
  • Thanks I'll be getting another joystick this evening and I'm going to check into all of this!
  • So I seem to have solved the issue! I switched pulling 5v from the 3 pins on the RC input to pulling 5v from Vcc and the pot switch no longer is getting hot!!! Thanks for the assistance man!