EN RU CN
Bluetooth
  • Question, anyone got the bluetooth function working? I bought 2 bluetooth Arduino Transceivers (see picture)

    http://curltable.the-yard.net/files/2013/02/bt_board_front.jpg

    but I don't get them to work. I think I connected it as it should be. I connect the TX from the gimbal controller with the RX from the transceiver and the RX from the gimbal with the TX of the transceiver. My laptop has no problem finding and installing the transceiver but when I try to connect it wit the GUI, it just doesn't do anything. When I press the CONNECT button in the GUI I see the transceiver connect (the LED stops flashing and stays on) but nothing else happens. Does anyone know what's wrong?
  • Check the serial baud rate value set in GUI. This value must be the same as the transceiver's default baud rate. Try to change to 115200 in GUI, this might be the default value of the transceiver.
  • I have a similar issue and transceiver. Can get it to connect with the PC and i get a solid red bluetooth connection light but like the OP the GUI just sits there trying to connect.
    Looked at the bluetooth device properties and it seems to be 9600 baud, changed that in the

    ANYONE got a bluetooth module to connect to the base cam board?

  • I have the same problem.
    Application interface does not connect
  • I hope it's a firmware bug, and in the new firmware they fixed it. There are people that got it working, but after buying 2 different BT boards I stopped trying. Word is, the new firmware is coming soon! So I'll wait my time!
  • Any word from Basecam here? are we wasting our time trying to get BT to work at the moment??
  • True not sell this product that is not working with ALEXMOS BASECAM V.2.1
  • I got one used the board "http://www.electrodragon.com/w/index.php?title=BC04".
    And default baud-ratio is 9600, after changed it to 115200. It work will on my Alexmos.
  • For all those who have the constant 'connecting...' issue where the bluetooth module seems to never connect to the GUI, heres a fix that worked for me (with Mac , parallels and the latest 2.3b5 FW and 2.3b4 GUI.

    I reversed the TX and RX wires and it connected, doesn't seem to matter the baud rate now and is connected and giving live data via BT and 115200.
    YAY.

    Not sure what the deal is with the board or BT unit pin markings but this was at least a fix for me!
    cheers
    jason
  • Anyone connected a bluetooth module on a ArmBGC V3.0 board? I can't find any relevant info and there are no pin markings on the board.
  • It took me some time, but I finally found the problem why the bluetooth function didn't work. First of all, it has nothing to do with the Alexmos board! It has to do with you BT board. Some are programmed with the right baudrate, but most, are set to the low baud rate 9600. You need them to set to 115200. When installing the BTboard in windows you can set the baudrate, but actually it's not set at 115200. You need a USB TO RS232 TTL PL2303 CONVERTER first to program the BT board the right way. You can buy a usb to Rs232 TTL converter from ebay for a few $ inc shipping. http://www.ebay.com/sch/i.html?_trksid=p2047675.m570.l1313.TR0.TRC0.XUSB+TO+RS232+TTL+PL2303+CONVERTER&_nkw=USB+TO+RS232+TTL+PL2303+CONVERTER&_sacat=0&_from=R40
    In this video they show you how to set everything up.


    I hope this will help everyone with this problem!!
  • Hi
    I found the problem The Bluetooh of RCTimer Works without problem and without programming.
    There are only changing the cable TX & RX.
    http://www.rctimer.com/index.php?gOo=goods_details.dwt&goodsid=764&productname=