2.2b hex file not uploading
  • I have a board from flyduino with the correct labels on the back, but I am having problems getting v 2.2b uploaded to the board. 2.1 works fine, but after uploading 2.2b the board does not boot up (red led, but no green comes on) and the GUI cannt connect.

    This works: avrdude -c arduino -p atmega328p -P /dev/cu.SLAB_USBtoUART -D -V -U flash:w:/Users/muthm/Downloads/SimpleBGC_2_1.enc.hex

    But this does not avrdude -c arduino -p atmega328p -P /dev/cu.SLAB_USBtoUART -b 115200 -D -V -U flash:w:/Users/muthm/Downloads/SimpleBGC_2_2b2.enc.hex

    Here is what the GUI java command like says:

    When I run the 2.2 GUI and firmware i can see this in the java log after I hit connect in the GUI:

    19:53:01,841 INFO Opened /dev/cu.SLAB_USBtoUART / EDT
    19:53:04,901 INFO Starting board connection.. / ConnectThread
    19:53:04,904 INFO Send command: [V,0][]0 / ConnectThread
    19:53:05,205 INFO Setting baudrate: 57600 / ConnectThread
    19:53:05,207 INFO Send command: [V,0][]0 / ConnectThread
    19:53:05,507 INFO Setting baudrate: 38400 / ConnectThread

    When I do it with the 2.1 GUI (and firmware) I get this:

    19:58:06,275 INFO Opened /dev/cu.SLAB_USBtoUART / EDT
    19:58:09,334 INFO Starting board connection.. / ConnectThread
    19:58:09,336 INFO Send command: [V,0][]0 / ConnectThread
    19:58:09,340 INFO CMD received: V / SerialPort
    19:58:09,340 INFO boardVer: 100, frwVer: 21, betaVer: 0, deviceId: [-49, 7, -35, -91], licenseKey: [0, 0, 0, 0, 0, 0, 0, 0], activated: true / SerialPort
    19:58:09,637 TRACE Saving application settings... / ConnectThread
    19:58:09,646 INFO Starting realtime data thread.. / EDT
    19:58:09,647 TRACE Saving successully connected port "/dev/cu.SLAB_USBtoUART"... / EDT

    I have tried various hex uploaders on win and mac as well as doing it with power, no power and motors connected not connected.
  • Have you asked flyduino about this issue? I have no their boards to test.
  • Hi Alex - yes I have, Paul offered to flash the firmware if I sent the device back. I wanted to see if there are other ways so I don't have to send stuff back and fowards.

    BTW - I am really looking forward to get this working, you have the best 3 axis solution out there, especially with the Follow Mode!
  • Hello muthma,

    I had the same problem, when setting up the Alexmo fromFlyduino (Win7)
    GUI said, it´s 2.0b3 loaded and it did not work with newer GUI-version (2.1, 2.2)

    Finally I got it to work by followin steps:
    - Uploading 2.1 via Xloader (checked the Firmware in GUI)
    - Uploading 2.2 via Xloader (Xloader sais "Uploade failed) but FUI finally accepted the Board and showed 2.2

    Unfortunately I fried my Board today by mistake