EN RU CN
usb doesn't work
  • hi, I just got my board from Flyduino after 3 weeks of waiting... but it doesn't work :(
    USB is not detected on any PC, I have also tried to use external FTDI to talk to the board - no chance. No communication at all - I tried flashing tools, the standard control tool for both 1.3 and 2.0...nothing worked.
    The board seems to be alive - I can see red light + green flickering, then after some time the green stays solid. But the uart seems to be dead... Any ideas what might be wrong? I am really upset, because I invested a lot of money into my equipment, then I waited a long time till I get the board and in the end it doesn't work :(
    I am a skilled embedded programmer, so I believe I didn't miss anything that could cause these problems... Thank you!
  • Hi stanley, at first did you try to contact to seller?
  • sure, I wrote email to Flyduino, but no response yet... I thought that here I get some hints from people who designed the board... In the meantime I checked soldering on the board, it looks fine to me. RX/TX signals are passed to the appropriate pins on Atmega chip.. I can hook it up to the oscilloscope in my office, but first I need to know if I didn't miss anything...
  • Perhaps you have got defective board, i advise you exchange it with your seller.
  • Hello, stanely!

    First of all, check that new COM port appears in you system when you plug USB cable. Second, try to upgrade to latest 2.0 firmware using AvrdudeR from here: http://www.simplebgc.com/files/AvrdudeR.zip. Use run.bat. Specify right COM port. When flashig started, GREEN should blink 3 times. It will show console output, if something like "Not in sync" - try the same on different PC (very rare issue, but some PC cant upload firmware). If failed, double check soldering RX, TX, Reset pins of Atmega (or re-solder it). If nothing work, sorry but you need to replace board by guarantee.
  • stanley, try to write to support@flyduino.net, i think you will get the answer.
  • hi Alex, as I wrote: no comport appears. Device manager doesn't even show faulty device. Nothing... I tried 4 different computers, on three I get no feedback, on 4th computer I see "unknown device" that is not responding. I tried to install drivers, it always failed (on the only PC that could at least see the unknown device).
    I have also tried 2 different FTDI adapters - they didn't receive anything from the board. I also measured RX/TX pins on the CPU, there was some voltage, but no communication (from TX pin on Atmega).
    I tried to pull Reset to GND - the board seems to reset, green led switches off, red stays lit. Then immediately after releasing reset, I tried to upload hex file using external FTDI interface... it was not communicating.
    It really seems to be faulty board :(
    I hope Paul will be able to replace it.
    Thanks for your help!
    Regards,
    Stano