EN RU CN
Follow mode in Angle Control
  • Hi !
    It seems that the follow mode is disabled automatically when you pass in SBGC_CONTROL_MODE_ANGLE.
    Is it possible to make it work ? If I have a 2nd IMU on the frame it shouldn't be an issue, is it ?

    Maybe there is an option too in the SBGC_CONTROL_MODE_ANGLE_REL_FRAME but this mode isn't successful at all on my gimbal (seems to lag a lot, perhaps overwhelmed by the rate of the controls ? (100Hz, working fine in the angle mode)
  • Hello,

    With the CONTROL_MODE_ANLGE you pass target angle where gimbal should point (setpoint). Follow mode is another concurrent source of setpoint, so only one can work at a time. If you mean different control for different axes, now it can be done in 2.68b9 version.

    MODE_ANGLE_REL_FRAME is updated too, now it works better so could be used with high rate, if you do not set flag "CONTROL_FLAG_AUTO_TASK".

    Regards, Aleksey

  • BTW, if you need remote control together with the Follow mode, do not use mode with setpoints (mode_angle or mode_speed), use MODE_RC instead, which is compatible with the Follow mode. This way you can get remote control fluently mixed with the follow control.
  • Hello Aleksey,
    I'm back considering the CONTROL_MODE options, I made a remote allowing control in MODE_ANGLE with wheels. It works well but I have 2 questions :
    - first it seems the movements are a little rough in very slow motions, probably due to the high speed of the angle corrections. I have troubles understanding the differences between the MODE_ANGLE and the MODE_SPEED_ANGLE. This last one never worked well with me, but would it help for my slow movements ?
    - second I'm a little worried that this MODE_ANGLE won't support well little breaks in the RF connections. Is there a LPF inside SBGC wich could help in this case ?

    Thanks