EN RU CN
external IMU chapter 18 & 19 of manual
  • Hello, i have installed late beta software and i would like to use my Pixhawk 2.1 as an external reference to use as an aid for the gimbal.

    What i don't understand is what i need to enable to make it work, do i have to enable both connections? External IMU sensoe AND mavlink connection to my Pixhawk or just connect mavlink to my pixhawk and it'll be used as an external imu too?

    Since i am experiencing a problem with mavlink (it stops working after a minute or so) i am just wondering if maybe i am making a mistake connecting my flight controller in both ways on same serial as an external imu and as a flight controller.

    I went trough the instructions a number of times but it is still not clear to me what needs to be done.

    Basicly, what i am referring to is chapter 18 and 19 of the instruction manual, and since i want to have my flight controller to help, do i need to connect the FC in both ways as described in chapter 18 and 19 or just like in chapter 19 with mavlink and i am done?

    regards,

    Corrado
  • Hello, problem gets worse. Mavlink connects and looks like it is working ok, than all of a sudden it hangs up and no data come trough the serial.

    It looks like it hangs whenever i try to send a mount command from the mission planner. Actually it looks like it hangs even if i do nothing but issueing a command crashes it instantly.

    regards,

    Corrado
  • Hello!

    You need only a Pixhawk connection via Mavlink. Once you set it up, you select the "MavLink" in the "External IMU type" to use a correction from it.

    "Since i am experiencing a problem with mavlink (it stops working after a minute or so)"
    "Hello, problem gets worse. Mavlink connects and looks like it is working ok, than all of a sudden it hangs up and no data come trough the serial."

    - try to use the latest beta firmware 2.68x. I remember such problem was in intermediate versions, but currently it is fixed.
    If the problem still exists, please write a bugreport to our support service, we will check it more detailed.

    Regards, Aleksei
  • We tested latest software beta and still experience hangs on mavlink, sometimes it stays up for up to a minute, sometimes it locks in few seconds.
    My collegue opened a bug report on the site, thanks for your help.

    Corrado
  • Hello, is there any news on this?
  • Is there any news by any chance? Our gimbal is useless at the moment since it locks up on mavlink connection after few seconds.

    Please let us know if you could replicte the problem and working on a solution.


    Thank you,

    Corrado
  • Hello, 2 weeks has gone by from our first post and bug report. We didn't have any feedback yet and we don't even know if it is our configuration problem or a bug in the basecam software.

    Can we please have some kind of assistance? At least know if it is a common problem and it is being worked on or it is just us doing something wrong.
  • Has been 2 weeks since we have had this problem (mavlink hangs up after few seconds) and we really spent countless hours trying to understand where the problem is. We would appreciate very mauch a sign from Basecam, just to know if you can replicate the problem or it is our configuration fault. We have only had 1 forum message from Alex 10 days ago and since that nothing. We wrote to basecam email address, opened up a bug report (should answer in 24 hours, so they say) but no available. No solution and no answer to whatever form of comunication we try. Just complete silence.

    regards,

    Corrado
  • Just to update the situation. I wrote here and directly to Alex, we opened a bug report but as of today i haven't had a single word back from basecam for my mavlink hanging problem.
    Only word from them is the post in this thread from 2 weeks ago.
    As previously stated i do not pretend a fast solution but at least know if they recreated the bug and working on it or if it is my fault and have to look in my configuration (been looking it for the last 3 weeks and no issues found).

    Please Alex could you answer to my message, my emails or my bug report? Just an answer is what i am looking for.
  • Is your problem fixed with the new beta fw?

    2.68b6
    - Bugfix: MavLink connection may hangs undr some specific conditions
  • Hi,
    This bugfix with the 90% probability relates to this problem: ".. problem gets worse. Mavlink connects and looks like it is working ok, than all of a sudden it hangs up and no data come trough the serial..."

    With the new version, connection (at the protocol parsing level) should not hang. The way how MavLink messages are processed after parsing, was not affected.