EN RU CN
Pitch motor twitching up and down.
  • My pitch motor twitches up and down as soon as the gimbal gets power. i tried resetting the board several times and doing the imu and gyro calibration over as well. i have also tried several stabilization settings and cant seem to get the twitching to go away. how do i fix? is it the imu sensor that is the issue? is it the pitch motor?
  • Hello,

    Can you make a video showung this problem?
  • turned out to be an issue with the main imu cable sitting above the camera, however i ran into another issue, the rc signal for my yaw dances between 1500 and 1501 causing a very slow rotation of my gimbal over time. i have set the RC sub trim by auto and changed the deadband as well but slow rotation is persistent.
  • The dead-band should solve this problem. Just set it wider until drift stops.
  • i have tried several times but i am failing to get the drift to go away. i removed the joystick and the drift is persistent. immediately after powering up the gimbal the yaw motor starts to drift left it is not as slow as before this time it is fast. upon powering up the gimbal will turn a full 180 degrees in about 10 seconds. i tried recalibrating acc and gyro using leveling cubes to ensure a well balance. what am i missing here? also if my joystick needs to be calibrated how do i go about doing so?
  • i have calibrated the joystick as well still no help. i held up the gimbal and allowed it to fully rotate to see where it stops it just keeps going in a full 360 on the yaw axis. here is link to the video i took of the issue at hand. sorry about the angle. www.youtube.com/watch?v=lAHBBN3YP3M
  • www.youtube.com/watch?v=lAHBBN3YP3M
  • From your explanation and video I can not understand what is the reason of a drift.

    If drift is caused by RC:
    The RC value displayed in the RC tab or "monitoring", should be 1500 in a neutral position of the joystick. Find a range of variation of this value, when you move joystick and leave it - normally RC value does not return to 1500, for example it stays at +-50 from 1500. Set this value as the "Deadband" parameter.

    If drift is caused by the IMU:
    - Enable the "Follow" mode. Drift should stop after a while
    - calibrate gyrscope. drift should stop or become much less.
    - check all is okay with the IMU sensor. See the "Monitoring" tab, GYRO_x signal. It should have random noise no more then +-3-5 units.

    Regards, Aleksey