EN RU CN
wtf happened?
  • Hi everyone, I'm currently three hours into trying to sort this and have crawled this forum and google for everything that might be related, please help if you can!

    hardware - Varavon Birdycam 2 Gimbal (For video)
    board - Basecam Ver 3.0 32-bit
    iMac - High Sierra
    Firmware 2_59b1

    Ok, so the gimbal when I got it a few months ago was working great, but then the roll got out of wack and it held the camera at a slight angle from the horizon. Being ignorant of all of this part of the tech world, I tried for weeks to get ahold of Varavon, eventually I had to mass email ALL of their listed dealers. Only after one of their dealers so kindly championed for me, I eventually received a poorly written and erroneously coded email that suggested I download SimpleBGC, and use their pdf walkthrough to try to calibrate and update the firmware.

    ~Download SimpleBGC 2_59 from Varavon's link on their website.

    Consistent freeze while attempting to download FW that ends in a force quit of the app EVERY TIME. This is all I see:
    _____________________________________
    Pausing monitoring..
    Signing request..
    Entering boot mode...
    Waiting for bootloader to start...
    Downloading firmware...
    Downloading firmware...
    ____________________________________

    ... ... ... ... F ... O ...R ...E ...V ...E ...R ... ...P ...A ...S ...S ...E ...S ... ... ... ( <-- Just like trying to type all of that nonsense)<br />
    Current Status = Paper weight

    So eventually I said, "Screw it!" and walked away for a few days while waiting on an email response from them... fast forward about a month and some change... no response, but some change...

    Had a shoot coming up and need the gimbal, so I went into the GUI and wiped the EEPROM (Per their guidelines in the "Dr. Varavon" pdf manual). When I tried to write from their .profile files I kept getting an error that I did not have access to write to the board (Fully Connected and live monitor of positions, after I had erased it, mind you)

    Current Status = Still a paper weight

    A week later and I'm back at it... two months and still no response from 5 emails to Varavon (horrible customer service for other contact related reasons too), well... I've figured out to come to the Basecam website and start fucking around...

    ~Download SimpleBGC 2_63 (current)

    Still to no avail, I ended up downloading a few older versions of the software and after two hours of swearing and this gimbal beeping at me literally nonstop (looking for IMU calibration as I understand) I FINALLY was able to load the 32 bit recover .bin file.

    Current Status = After much ado - A paper weight that I can calibrate.

    ~Back to 2_59 (or something) so that I can get the FW and GUI to match, still cannot auto update FW.

    Finally - Rewrote the EEPROM from Varavon's supplied .profile files.

    Current Status = Still a paperweight, but after power-up, it beeps several slow tones OR one long tone, then the fast calibration beeps (sometiemes). I can switch profiles from the joystick controller, but I have ZERO movement (compensatory or directed). So it seems no matter what GUI I use, what firmware I try to write, or any what... I continuously get an error that accelerometer is not calibrated and "License is not valid, firmware can not be run in this board..."

    ~So... Its just a $1200 paperweight. I'm willing to send it into a service center if I need to, but I don't think that should be necessary, I'm sure its simple.

    Thank for anyones help!
  • BUMP - Can anyone help? terms like "encoders" are getting thrown around, my encoders are disabled with about 10 options from each drop down, frame IMU is disabled, I recovered the board from a backup file and loaded the EEPROM that varavon supplied but still nothing from the motors... I would be glad to screenshare or something with someone... Fuck it, I'll pay if you get it fixed.

  • That could be somethign simple, but not possible to say by the description and it could be simply broken; the board, some cable... impossible to say without seeing it.
  • I have tons of pictures, what do you need to see? nothing broken on the board that I can see... From what I understand the basecam boards are opensource DIY based... can I not just start all over from scratch? it worked fine before all of this, just needed to be recalibrated from what I know now...
  • I more maent, to have it in my hands, it would be easy to see what is the problem.

    BaseCam is not open source, but yes you can and should do the complete tuning in case the settings have been lost. You can not just copy a profile from someone else. Motor inverted is quite possible different. also if it has encoders, their calibration is bretty sure different, and in any case you need to calibrate the IMU(s)

    What errors do you get on the information screen? what version of FW is installed.

  • FW 2_59b1 is currently installed. I have tried to calibrate the IMU but it says frame IMU is disabled. I can calibrate the sensor but I have no controls or anything. I am getting a license invalid error as well as "no confirmation on writing parameters for command 22, 34, 63. I have a host of files that were supplied by varavon including profiles, firmware, .data, .profile, eeprom stuff, encoder files, all of that... maybe I dont know the correct order to load and set everything??
  • update: basecam support is making me a FW file with my board SN number. I will keep this updated as I progress...
  • UPDATE: Varavon pulled through and connected via teamviewer and spent about an hour and half adjusting and running diagnostics.

    The controller is not distributing power to the motors. Battery is fully charged and powers the controller. All lights are on, sensors are working fine, just nothing to the motors. The software reports “battery 0.0” at all times.

    They offered to fix it for free if I payed shipping to/from Korea. At almost $725USD round trip, that’s not likely.

    Any ideas on what to look for? I’m very handy with a volt meter but I’m not sure where to look. Maybe a new 32bit controller? I’d rather spend $100 than $725.

    Thanks!!
  • Hello,
    Did you try to calibrate battery? You can enter real battery voltage (2): push CALIBRATE button (Service tab), check battery voltage by multimeter and enter in the input field.
    http://ybex.com/d/h4m7gnpqlq5pflsblw16auv8w36bsui7lbf6eibq.html
    Also select battery type in drop-down list below (1).
    Write settings to te board.
  • blacktophat, I wrote in your a new topic, you need to take a photo, and then we can mark the points for testing.
  • Anytime I write to the board I get error:

    Something goes wrong when writing parameters:
    -No confirmation on writing parameters for command 22
    -No confirmation on writing parameters for command 34
    -No confirmation on writing parameters for command 63

    So I'm not sure if it wrote the calibration or not, nothing changes so I assume not.
  • Also I'm not sure where or what I would enter for battery type???
    It is a:

    Anypower T-Power 7412
    Li-Ion 3.7v 10400mAh
    output 7.4v/12v 2A
  • "Anytime I write to the board I get error:"
    - Try to use latest GUI: https://www.basecamelectronics.com/downloads/32bit/#latest


    "Also I'm not sure where or what I would enter for battery type??? "
    - Could you check voltage of fully charged battery (on + and - contacts) by multimeter?

  • FINAL UPDATE!
    Thank you to everyone who commented or reached out personally, to @AndrewSupport and the basecam team. Andrew sent me the 2_63 FW file with my SN embedded and she works perfectly now, so far as I can tell. Battery issue is resolved as well. I'm still not 100% sure what went wrong where but its resolved now. I have many many emails and screenshots, and a 48m screen recording of varavon remote session with me that I will be happy to provide to anyone that may need them!
    Thank you all so much!!!!