EN RU CN
SSL Error Updating Firmware
  • I've recently received a new 32-bit Simple BGC. I've foolishly reset it it the "recovery firmware" and am now trying to update to the most recent firmware but keep getting an SSL certificate error. It looks like this has happened in the past and BaseCam has been able to resolve it with an SSL update on their end. Is anyone else having this problem? Any suggestions as to how I can fix the issue? I did submit a "help" request to Basecam yesterday but haven't heard back.

    Thanks for any help
  • Hi,
    Long time ago we had this problem but solved it with the GUI update. Is it happens with the latest GUI version? Can you show error message here?
  • I've tried using several versions of the GUI, all of which were downloaded in the last couple of days.

    "Error checking latest versions: Java.lang.Exception: Error sending HTTP Request: javax.net.SSLHandshakeException:sun,security.validator.ValidatorException:PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
  • Other our users does not report about such problems, and we can not reproduce this error on our machines. I guess it is something related to your machine. May be anti-virus protection - some of them replace SSL certificates to their own, making additional checking.
    Also it might be too old version of Java, that does not have root certificate of trusted authority center in its database.