Not able to load v2.0 firmware hex file into SimpleBGC
  • I tried to flash simplebgc with the new firmware but it tell's me 'upload failed'. This was for XLoader, I tried also with Avrdude and the interface just don't respond after I clicked on the 'Flash Firmware' button.
    Do any one have an idea on what's wrong ?

    Platform : Windows 7
    Baudrate = 115200, etc.
  • I had the same problem. I tried several times and always got the message "upload failes"
    But when I tried to start the new gui everything was ok. Its a mistage in the X loader.
    Platform_: Win 7
    Baudrate : 115200
  • This is normal Xloader says upload failed, but the way to check if it has been successful is the board should reboot after the flash, it it does upload was successful
  • Seems rebooted but GUI did not recognized the firmware. I tried another arduino hex uploader and it works very well : http://www.ngcoders.com/downloads/arduino-hex-uploader-and-programmer/. GUI now recognize the 2.0b3 firmware but I got a new problem. All defaults values (PID, motor power etc.) load in the GUI but the I2C errors label value is increasing very fast (seems there's many I2C errors happening).
  • Ok I just checked 'I2C pullups enable' in the 'advanced' tab and all works fine !!
  • After updating to V 2 I had the next problem. I did not connected my RC receiver and the sensors
    behaved very strange and moved the whole time. After connecting the RC receiver everything
    worked fine with my old settings. The most important feature for me is the timings setting
    set to silent. Great improvment.
  • The same problem for me, 2.0b4 "upload failes" running X loader. Platform_: Win 7.
    But with bergy35 recommended ARP uploader i worked out just fine
    after changing command line from default 19200 to 115200.
    And micro-controller to type "m328p"

  • I've tried every uploader mentioned and I'm unable to flash any new firmware. My board came with 1.3 installed. I updated it with a Martinez version, which isn't working well. I wanted to upgrade to 2.1, but none of them will successfully upload the firmware. The GUI won't recognize the board.
  • Update - I was able to use Xloader to install the 2.1 firmware. However, when I open up the SimpleBGC GUI and try to connect, all I see is the red LED blinking on the board. The green LED showing data traffic never comes on. I'm unable to connect and set the parameters. Any ideas?
  • I got the same problem,
    My board is working fine with 2.03b. However I do update to 2.1 with Xloader but it said fail.
    I reduce the comport to 57600 bps and it said upload finish. But after that I cannot connect to board anymore even using 2.03b GUI nor 2.1 GUI. The red led On permanance and the green some time blibk but no connection.
    Is there any how to fix this? and reload the firmware?
    I amusing windwos 7 64 bits.
  • Hey guys, if you have original SimpleBGC, contact to your seller for solving your issues.