EN RU CN
Firmware: 2.63 bricked my 3.0 board upon manual update into 0.00 b0! (basecam4.5) HELP
  • Hey, this page was offline with all forums yesterday or even more. My GUI couldn't connect for this reason I believe, so automatic update gives Java Error 500, and still does. (2 different windows systems tested, GUI 2.43, 2.60 and 2.63 not working automatic)

    Situation:
    - Before I have been running on 2.60 (auto updated) as firmware since a while and now found 2.63, which I tried to update automatically. This was no option as the Java error couldn't connect to basecam on version "CHECK" button. So I tried to manual update the board with the included firmware recovery file of 2.63 GUI that is found in the firmware folder of it.

    - The manual update seems to work repeatively without errors (all OK) on 32bit COM PORT method for example. The update closes with a successful message.

    - The Board LED is on red light when updating, once done blue and red steady on. Upon "connect" button the red light is steady on and blue blinks.
    - Board: version 3.0 Firmware: 0.00 b0 is the actual and final result

    --> Gimbal not working anymore

    Solutions tried:
    - I updated all possible manual ways (jumper method, though there were holes only, automatic failed upon connection error, GUI 2.43, 2.60 and 2.63 recovery files that come in the firmware folder on manual update - all via the same USB cable that worked before best only)
    - I googled the heck out of the topic and loaded "cached basecam" pages since all was offline, but no success on my case


    Anybody can please help me with this? The board is needing to accept its firmware somehow, seems to be empty.
  • You don't have real firmware on there. You've wiped it clean and now all you have is a type of "placeholder firmware" whose only real purpose is to enable you to do automatic firmware updates. This is totally normal. You just need to go to firmware upgrade -> automatic now and do the firmware upgrade.

    I guess I'm not completely clear on if you've tried to to an automatic upgrade at this point or not. Normal procedure is to flash (if needed, which is rare) using the manual jumper method and then do the automatic upgrade. The manual flashing procedure leaves you with the 0.00 firmware listed and usually I find that it beeps annoyingly until you actually put a real firmware version on it.
  • What you write seems to be correct. Keeps me breathing for hope, too.

    Reason I did manual Flash in either method, is that I can not do the automatic upggrade in all the above named GUI versions. All have a Java code 500 error, which appears to be some connection issue. I recently updated Java, but the old Laptop has the same issue.

    The Basecam webpage was offline more than a week according to a "isitdownorjustforme" check. So maybe it's still recovering the java access portal?

    I'll probably keep trying to automatic update firmware during the week, unless you can tell me something on my end is wrong with java.


    Here the full Java Error message after pressing "check" button for latest version:

    "Error checking latest versions: java.lang.Exception: Error sending HTTP request: java.lang.Exception: Invalid http response code 500: sbgc.firmware_info: Wide character in subroutine entry at /usr/lib/perl/5.14/Encode.pm line 196."

    What Java programmers say about it? "That error means 'Internal server error'. I think it might be caused by doing a regular request to an SSL host (See the httpS prefix in the url). You are probably not sending a valid HTTPS request, and the server handles this incorrectly by raising an unhandled error."
    _..--> Server sided error


    (Also as sidenote: Does this not render the manual flash worthless? If automatic has to be done afterwards yes or yes to get the board to work - what if basecam servers are offline one day? Boards would become useless - haven't had that kind of stuff yet. I thought manual is for this exact scenario, where the servers were dead for what I saw more than a week, barely a cached manual to find without pinout pictures, and my only resource were mirrored GUI downloads which had included a firmware for manual flashing o.O)
  • That doesn't sound like a board issue at all. It sounds like something to do with the server or your computer. I did look up the "Wide character" thing and I have a crazy question for you. Do you use any unusual characters (non-English) in your e-mail address or anything like that when upgrading? Try just hitting Skip for e-mail entry if so.
  • By using SimpleBGC_GUI.exe to make this "check" for a new version, there is never an email contact relevant.

    Basically I can run this app fresh in the temp folder of a new unpacked zip download of the program and there is no email field required.

    And yes, it should be server sided, since all versions I tried on 2 computers give the same error result. Some kind of httpS problem more likely, to do with certificates. (unless it's country specific bad internet)

    How about you simply do the thing (pressing the check button) and see if you don't get the same error. If it is server sided, everyone in the world will get the same result.
  • Hello everybody,
    Try update your board again. We solved this problem, and now update is available.
  • That is great news!

    It works now. 2.63 b0 is recognized. *thank god... i mean support team!!

    Final verdict:
    Please implement for the future, that manual flash does not lead us to a 0.00 b0 firmware and an unusable device, but rather it should flash to the actual version that comes with the GUI!
    'That'd be great!' :)