EN RU CN
SimpleBGC not connecting to board
  • I've searched through the forum and not found a fix so thought I'd ask for some advice.

    I have a gimbal based on a CAME7500. This has not been used for a while but was and is fully functioning. I want to make some adjustments to the setting tho so I'm trying to connect to it with the latest GUI. I've had no issues in the past but for some reason it just refuses to connect.

    My setup:
    Gimbal with 32bit board (CAME based)
    SimpleBGC GUI 2.63b0

    My issue:
    When I connect my board to the computer via USB it beeps and the red light lights up.
    When I open the GUI I see the com port in the dropdown. Both on the PC (WIN10), where it shows up as COM3, and on the Mac (10.12.6), where I have 2 ports (dev/cu.SLAB.USBtoUART and dev/tty.SLAB.USBtoUART).
    When I click connect the status of the board reads "connecting to COM3" (or the Mac equivalent when on the Mac) but it never connects. Simply stays in that state. I've check that all the various drivers are up to date but still the same issue on both the Mac and the PC.

    I've tried both with the battery connects and just the USB connected. Gimbal works just fine I just can't seem to connect to it.

    Where do I start in troubleshooting this? Anything I should check? Any ideas?

    Cheers
    Adam
  • the first problem is your using new GUI with old firmwear !
  • How do I know what version the old firmware is? If I want to update the firmware I'd need to be running the most recent GUI, correct?

    The problem is I'm not even able to connect at this point. Even tried 2.60b4.
  • Firmware obviously isn't the problem here. The first command sent by the board after connection is to find out the firmware version. It can send that command with the wrong firmware.

    The board could be bricked, in which case you could try flashing the board, especially if a firmware upgrade failed. The board could also be dead. Another option is that your USB cable doesn't have a great connection. Try another cable.

    First of all, just pull the cable, unplug the battery, shut down the GUI and start everything over again. Once you get one failed attempt, you need to bring everything down. This board doesn't easily let go of a failed connection if you fail to connect the first time. You have to remove all power and shut down the GUI. THEN bring it all up again.
  • The board beeps when I connect the USB cable. So it's recognising that there is a connection.

    The board also works correctly and maintains balance and stability when a camera is mounted and balanced. So it would seem there is no issue with the board being bricked or dead.

    Tried different USB cables and all do the same thing. "beep beep" when you connect the cable and the lights on the board light up. But connection via SimpleBGC GUI app simple never connect.

    Any other thoughts?

    Cheers
    Adam
  • Next step would be to try it with a different computer.
  • As in my original post I tried it on both Windows and Mac. Same result. Will try another machine later in the week.

    A

  • Hello!
    I recently bought DS2A beholder and it's not connecting to board i tried all the possible options whatever the people say in youtube videos i did but still field. I read all the SimpleBGC 32bit 3-Axis Software User Manual and followed all the instructions but nothing worked. I have macbook pro 2013 i make folder on terminal (sudo mkdir /var/lock) and the password which should be this one (sudo chmod 777 /var/lock) the keyboard is not writing anything. also Security & Privacy I unlock anywhere but still cannot make a folder. Any idea what to do? Regards