EN RU CN
PID auto tune fails and encoder calibration fails due to number of poles error...
  • I'm not able to use the PID auto tune or calibrate my encoders using the "CALIB. EL. FIELD" button.

    I'm using SimpleBGC32 GUI v2.63 b0, board version 3.6, firmware 2.66 b0, and 3X of the following motors:
    http://www.iflight-rc.com/ipower-motor-gbm4114h-120t-gimbal-motor-with-as5048a-encoder-compatible-with-slipring.html

    All the relevant values on the "Monitoring" tab look good (which indicates that everything is hooked up and working properly), I've calibrated my IMU, and stabilized the PID controller manually.

    when I try to use the PID "AUTO" tune feature it either fails or converges on unusable values. When I try to use the encoder "CALIB. EL. FIELD" feature it fails and warns me that the number of poles is incorrect or the motors are inverted incorrectly. I'm using 22 poles and what seems to be the correct motor inversion but with no success (I've also try other pole numbers).

    I've seen in other posts that the error might not be correct and the cause could be either the "outer motor tilt angle" or the PID tuning isn't stable enough. I'm not using the tilt angle and my gimbal doesn't vibrate or move at all during the encoder calibration.

    Is there anything else I should look at? What other conditions could cause these problems?
  • I have the same problem using the latest 2.66b0 firmware and also stable version 2.63b0.
    When I downgrade to 2.62b8 I can calibrate el.fields without problem.
  • UPDATE:
    I can calibrate encoder el.fields with 2.66b0 firmware version by using 2.62 version of GUI.
  • Regarding encoder calibration:
    Please provide the exact text of error that you get.
    Follow all recomendations of our reference manual for using encoders with SBGC32.
    Notes
    - calibration should be done in a "normal" position;
    - the "field offset" and "offset" parameters should be set to zero before calibration;
    - camera is perfectly balanced on all axes;
    - motors have enough torque to move each axis without loosing synchronization;
    - It should be no obstacles for free rotation during calibration.
  • Hi Alexey,

    sure, I was following all steps described in manual and tips from basecam forum...
    Here is a full message:
    basecam_encoder_error

    All parameters in encoder section are set to zero, I even used bubble level to keep gimbal horizontally.
    Gimbal is balanced very nicely and gimbal works great on 2.62 version of firmware.

    btw, I checked it few times. Using GUI 2.63b0 and 2.66b0 I always get this error. Gimbal don't even start moving, emergency stop occurs just when motors should start moving.

    With GUI 2.62b5 I don't have any problems calibrating el.fields.



  • I guess the problem caused by wrong value of the parameter "Angle to move during calibration". It's default value is 40. http://ybex.com/d/z7b67zzxl4r7ruui8tcxxkaiechwvl88fdh89t4k.html

    Have you idea why and where it got zero value? In new GUI I will give a warning message if value is 0.
  • Yes, that makes sense :) Thanks Alexey... As this option is new I didn't bother to read all options and I set zeros to all fields as described in manual. I didn't get any other error by setting it to zero.
    Also, I erased EEPROM to see if it helps but as I can remember default values for this field was "0".

    It will be great if you can set default value (40) using new versions of GUI and also update manual.

    btw, I don't have access to my gimbal at the moment but changing this value to 40 will probably fix this problem.
    @arbuckle Have you solved your problem? Does it solve problem by entering "40" in field for "Angle to move at calibration.