EN RU CN
How can I fix I2C error problem?
  • I have two problems.
    First one is that If I choose 23 for num.pole of Yaw, I can use it for a while however EC1 soon keep spinning toward 3 axises when I try to use it. And I found that EC1 has to have 22 for num.pole of Yaw.
    Second one is that if I choose 22 for num.pole of Yaw, EC1 start drifting with fast speed toward yaw axis. I cannot use EC1 at all. Therefore 23 is better than 22. I don't know why.

    Two problems, which are spin toward 3 axises and fast speed drifting yaw stem from same cause I think.
    It is I2C error. In GUI, If I use EC1 like tilting my camera, I2C error occures and keep increasing and never stop.

    Therefore I have to stop I2C error that occur when I try to use my EC1.
    How can I stop I2C error?
    Or Do I have any other cause that I don't notice?

    I really need to use my ec1 this weekend.
    Please help me.
  • There is only one correct number of poles, that is the actual number of poles on the motor.

    It sounds you have some hardvare probem on your gimbal and hense the i2c errors.

    It sounds also that you settings my be wrong. you should never have any need to touch the number of poles after they are correctly set.
  • If you go to the monitoring tab, what are your gyro readings? if they aren't between -3 and 3, then you should probably calibrate the gyros. This is one possible cause of the drifting. Based on http://www.cnchelicopter.com/blog/beholder-ikan-ms1-ds1-ec1-camera-stabilizer-pid-etc-support-blog/ it looks like it should have 22 poles. Leave it on that and forget about 23 poles.
  • Thank you for your comments.

    OK. I choose 22 poles.
    My gimbal keep spinning toward yaw axis.

    > eutico
    On monitoring tab, I have -3000 on GYRO_Z, 500 on GYRO_Y, 100 on GYRO_X with 22 pole.
    I have the number of between -3 and 3 with 23 yaw pole.
    Even after I calibrate the gyros, spinning problem remains.
    Maybe I don't do correct gyro calibration or gyro calibration is not cause.

    Do you have any other way to stop spinning yaw problem?
  • It's not 23 poles. What firmware version do you have? Maybe there's a video on calibrating the gyros for that version. Make sure that your motors are off when you calibrate the gyros.

    It really depends on how fast it's moving. Sometimes having the inputs set to ADC1,2,3 on the RC tab can also cause spinning, if you don't set them up right, but it sounds like there's a problem with the gyro calibration. You could always do a video of the monitoring tab and how you are calibrating and post a link to it here.

    Honestly, though, if you have a lot of I2C errors, then you have to solve that problem, and that is a hardware problem that you would have to contact the company to solve.
  • I'll keep 22 pole.
    I have 2.65 b9 version.

    I know the 2 ways of calibrating the gyros.
    First way is that "calibrate at system start" and Second way is that calibrate it in sensor calibration helper on hardware tap.
    Even If I calibrate gyros with Motors are off, same problem remains after motors are on.

    I'll make a video.
    Thanks.
  • I made a video for my problem.
    I really appreciate if you know how to solve it.

  • Difficult to understand what is going on, move the gimbal like you would be using it for filming.

    I2C errors are problem on the gimbal wiring most likely, maybe slip rings
  • I disagree that the I2C errors are the main cause of your problem, although they probably cause some problem. The reason I say this is that the I2C errors aren't rising fast enough to cause any real problems during much of the time that you have bad problems.

    Nevertheless, they are a problem. It's a hardware problem that the manufacturer needs to fix. That being said, I noticed that the I2C high speed check box was checked, and you might find that you get fewer errors with that unchecked... or not. I don't use that, so I don't have a lot of experience with it.

    Your yaw axis is spinning pretty rapidly. I've seen that happen when the encoder calibration has been wiped out for an axis. Have you tried recalibrating the pan encoder, or seeing what happens when you turn off the pan encoder? What are your encoder settings for that axis?

    > Difficult to understand what is going on, move the gimbal like you would be using it for filming.

    I agree.