EN RU CN
Tuning driving me crazy. ROLL and YAW are twitching and going crazy.
  • I have tried almost every permutation of firmware and options. I cannot get the PITCH and YAW to work properly.
    Currently on firmware 2.61b8

    Here are some pictures of my setup:
    https://goo.gl/photos/3K9ijD8LcRkTQ9kBA

    The pitch is the only one that works works fine but the Roll and Yaw twitch uncontrollably. The ROLL just goes to one extreme immediately after being powered. I am not too worried about the YAW but without proper roll, the setup is useless.

    Accelerator and gyro calibrated several times.
    I tuned the PID's with several values but the result is always the same.

    Any help is greatly appreciated.
    Regards,
    Diego.
  • Use the auto to define the IMU orientation on GUI.

    The IMU needs to be firmly fixed, and parallel to the main axis, your do not look well installed.

    It is most likely the basic setup that is failing. no use to do any PID tuning before it is correctly performed.
  • Thanks for the feedback. I tried the camera IMU on top of the camera and at the bottom.
    I used the auto IMU orientation every time. I understand the axis and the auto matches what I would manually do.
    No matter what I do, the PITCH works fine but the camera makes a hard anti-clockwise roll when powered. I can't get the ROLL to work.
  • I would to following:
    - 6 point calibration of camera and frame IMU
    - Very precise mounting of IMUs (IMUs must be parallel to motor axes and fixed firmly, don't use thick piece of duble sided tape)
    - Defining motors direction
    - Entering correct number of poles (AUTO function doesn't always give exact values, check specifications of motor)
    - Auto tuning
    - Enabling frame IMU
    - Make sure that all RC inputs are disabled
  • Something is obviously defective.
    I tried calibration a million times, secure IMU's, etc.
    Pitch works perfectly. Roll is always a disaster and YAW works sporadically.
  • One calibration is enough and to get it working one point calibration is enough.

    Something could be broken, but more likely basic setup is not correctly performed. it needs to be performed as according the users manual.