EN RU CN
Camera IMU doesn't respond
  • Hi,
    I got my new Basecam 32bit v3.0 board with two imu's. My firmware version is the latest 2.60b4. I tried to do the 6-axis calibration for both imu's. Frame imu went well, all axis got that mark next to them and all "compasses" show movement. But camera imu doesn't do that! I calibrated it and the board made all the right beeps. Still there are no marks next to axis and at the basic menu there is no movement at those pitch, roll and yaw compasses (don't know the right word for those..)! Any ideas whats wrong?

    Hope the imu isn't broken. I got the board from powerparts-uav, germany. At website they tell that they test all their boards before shipping.

    Thanks for advance!
  • You have seen the note about never disconnect the IMU when the board is powered ?
  • Not yet, but i haven't done that. The problem was there at the first time when i connected the usb and didn't connect the battery. So i trief to do the first calibration, but there eas no respons at the camera imu.
  • I have seen the note not to connect power to board before connecting all imu's first. I have done all the connections by the book. This problem came straight from the box. :/
  • Have you dressed the IMUs correctly, are wires ok, etc. Connect first only camera IMU and set the gimbal working with that. then add frame imu. To start the setup, 1 point calibration is enough. perform better calibration after the gimbal is working.

    http://www.levitezer.com/blog/files/961caec8b987076efd2f7ec37ca6bea0-27.html
  • Ok, thank you. I have to try of that works. I didn't have courage to try the camera imu by itself because i wasn't sure if its going to brake. Hope that works!
  • Why would it break? Just make sure power is off if you connect or disconnect anything, and Frame IMU you can disconnect from the user interface.
  • First of all are my imu's right way? Imu with two (2) wire connections is the frame imu and imu with one (1) wire connection (soldered) is the camera imu, right?

    http://proskyfoto.galleria.fi/kuvat/Gimbal/IMUs.jpg

    Well I connected only the imu with one wire connection to board and tried to calibrate it. Software didn't show any movement at all! There was nothing.

    http://proskyfoto.galleria.fi/kuvat/Gimbal/IMU+with+one+wire.jpg

    After that I connected only the imu with two wire connections. Software show immediatly movement and it can be calibrated!

    http://proskyfoto.galleria.fi/kuvat/Gimbal/Imu+with+two+wires.jpg
    (Hope the lilinks for pictures work!)

    So does this tell that the IMU with one wire is broken?

    BTW Garug, we are from same country! :D